Ratio adapter/VSS causing car to shut off??

SnakeMedic

Member
Joined
Aug 29, 2014
Messages
192
Reaction score
0
Location
Roseville, CA
I am having trouble figuring something out. On my 98 Cobra there is a ratio adapter from Abbott for conceivably different gears. Anyhow, my speedo has been off since I bought it. I was able to find a chart from Abbott (since out of business) on how to adjust the adapter. I went to try to do this and at some point the power wire disconnected from the adapter. I obviously reconnected the adapter, but now my speedo/odo do not work at all. Now, the car shuts down periodically when driving and slowing down when the RPMs dip. It threw a CEL, which stated speedo sensor. Cleared it, and it has not come back despite the car shutting off still.

Is this the VSS itself causing the car to shut off? Seems odd that it would suddenly go out as I was messing with the adapter. Wonder if somehow when the power supply disconnected to the adapter it messed up the VSS.....

I am so confused. Everything else works perfectly, car runs perfect until it shuts off, and starts up again like nothing.

HELP!!!
 

lutter94

Well-Known Member
Joined
Apr 11, 2008
Messages
3,026
Reaction score
146
Location
South Dakota/Iowa
If they're out of business maybe there's a reason its having problems. I'd rip it out and put a Ford Racing Speedcal in it, mine works great.
 

SnakeMedic

Member
Joined
Aug 29, 2014
Messages
192
Reaction score
0
Location
Roseville, CA
I dug a little deeper into the interwebs and did find some that have had the same problem and it turned out to be just the VSS. Tomorrow I have time to get down to it. Some say it is just the connection getting loose sometimes. We shall see.
 

SnakeMedic

Member
Joined
Aug 29, 2014
Messages
192
Reaction score
0
Location
Roseville, CA
UPDATE:

Unless I am an idiot, it appears I do not have a VSS and only an OSS. The wires coming through the hole by the shifter from the ERA (Abbott) connect into the wires that lead directly to an OSS unit, not a VSS like an otherwise stock 98 Cobra would have.

So from doing a bit of research on this, the thought it that I have a transmission swapped in from a 99+ car because of the lack of a VSS. How else would I be able to tell what transmission I have??
 

Latest posts

Forum statistics

Threads
75,145
Messages
1,456,463
Members
13,691
Latest member
rogue212005

Members online

No members online now.
Top