Seafoamed my 4v now it dies....

justinp95

New Member
Joined
Aug 5, 2015
Messages
12
Reaction score
0
I seafoamed my Cobra like a week ago and let it sit about 15 min (done this many times on all my vehicles) and started it up and started driving around the block and giving it an Italian tune up and it didnt smoke much. I was slowing down near the end of the run to stop and it died on my. I thought maybe i was running out of gas cause the guage was low. Got it back in the garage and put it away for about a week. Started it up to wash it and it will idle (pretty crappy and almost die) and when I rev it and let it come back down it just dies. Any ideas? No check engine lights.
Thanks

Yes i put it in through the PCV and replaced the PCV and insured the hose was nice and tight upon install.
 

justinp95

New Member
Joined
Aug 5, 2015
Messages
12
Reaction score
0
I figured it out! The New pcv valve looked the same as the old one but it was sucking on air from the top inlet. Looks like it where a second tube is supposed to connect. Does anyone have the part number to the correct pcv?
 

lutter94

Well-Known Member
Joined
Apr 11, 2008
Messages
3,026
Reaction score
146
Location
South Dakota/Iowa
RockAuto shows this for a 98 DOHC Mustang

581_POWER%20TRAIN%20COMPONENTS_PCV243_1__ra_p.jpg
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
28,250
Reaction score
3,842
Location
Evansville Indiana
looks like that little piece in the middle could be used to block it off after its snapped off?
 

Latest posts

Forum statistics

Threads
75,133
Messages
1,456,288
Members
13,688
Latest member
Pallgor

Members online

Top