Slight studder at start-up

Discussion in '96-04 - 2V Specific' started by kvoriley, Dec 5, 2014.

  1. kvoriley

    kvoriley Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Feb 10, 2014
    Location:
    Avon, IN
    97 GT PI swap, comp cams, tuned, etc... Everything including the fuel pump and injectors is new. When I drive the car for awhile and it gets close to operating temp, I will shut it off. I get in it an hour or two afterwards, and it almost seems like its not getting fuel for about 30 seconds. Runs funny almost studders if I rev it a little, but then it drives perfectly fine once warmed up a little.
    I am thinking fuel pressure regulator? It is the only thing I can think of that would be causing this issue. It has done this before and after the engine swap. But I was also looking at my fuel rail and it looks as if the fuel rail and pressure regulator are all one piece. There is no way to remove the stock regulator, but they sell a motorcraft regulator at O'Reilly's.
     
  2. Cornbread52

    Cornbread52 New Member

    Messages:
    24
    Likes Received:
    0
    Joined:
    Jun 27, 2013
    Location:
    SC
    Have you checked the fuel pressure when it does this?
     
  3. Ninety8stang

    Ninety8stang Well-Known Member

    Messages:
    1,000
    Likes Received:
    11
    Joined:
    Oct 25, 2009
    Location:
    Duh405
    Just throwing this out there because maybe it could be a possibility but maybe it could be a faulty IAT sensor. I would just go through and clean up the MAF as well and check your tps and it's voltage. At least this way you know they are in working order and wont have to spend money. Worth a try. Could also be something in the tune.
     
  4. 96blak54

    96blak54 Legend

    Messages:
    7,458
    Likes Received:
    772
    Joined:
    Feb 21, 2011
    Location:
    Ky
    Tru ^
     
  5. kvoriley

    kvoriley Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Feb 10, 2014
    Location:
    Avon, IN
    I've only checked it once, and not at start up when the problem occurs. I'm going to try and catch it soon and see if there is a difference.
     
  6. kvoriley

    kvoriley Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Feb 10, 2014
    Location:
    Avon, IN
    The tune is possible, but I thought I remembered it doing this before the engine swap as well, and MAF is clean, and the only thing that hasn't been replaced is the MAF and IAT , everything else is new. What are symptoms of a bad IAT?