surging probmes PLEASE HEALP.....

Discussion in '94-95 5.0 - Specific' started by fast5oh, Mar 27, 2007.

  1. ryclef331

    ryclef331 Well-Known Member

    Messages:
    2,913
    Likes Received:
    9
    Joined:
    Jan 20, 2006
    Alot of times it will be a grounding issue in the dizzy if they are loose. I had a salvage titled 95 that took me forever to try to figure out why I couldn't advance the timing....new TFI module, new coil, etc....turned out a screw holding down the PIP or pick up, rusted and broken through....the pip would loose ground when I would try to advance the timing past 0. I felt like a dumbass for that one...
     
  2. fast5oh

    fast5oh Member

    Messages:
    105
    Likes Received:
    0
    Joined:
    Jan 21, 2006
    well today i cleaned just about ever sensor i could find then i cleaned the TB and EGR. have not checked under the dizzy yet but i will tomorrow. once i got dont doing all this stuff today i took out all the plugs cleaned them up put them back in. and it ran great for about 20 miles then it started to freak out again i dont get it.
     
  3. ryclef331

    ryclef331 Well-Known Member

    Messages:
    2,913
    Likes Received:
    9
    Joined:
    Jan 20, 2006
  4. fast5oh

    fast5oh Member

    Messages:
    105
    Likes Received:
    0
    Joined:
    Jan 21, 2006
    yes i have done that. i have a few vids of my air/fuel ratio guage it just dosent seem right to me i will post them in a few.
     
  5. fast5oh

    fast5oh Member

    Messages:
    105
    Likes Received:
    0
    Joined:
    Jan 21, 2006
  6. Cobrakid

    Cobrakid New Member

    Messages:
    48
    Likes Received:
    0
    Joined:
    Jan 30, 2007
    that guage is a light show, throw it in the trash and buy a real wideband if you want correct info. can you post a vid of it driving when its having the problems?
     
  7. Downshift

    Downshift Well-Known Member

    Messages:
    1,957
    Likes Received:
    0
    Joined:
    Jan 21, 2006
    Im bored so ill update you guys haha. He changed out the plugs today and so far it went away. Those plugs just seemed way to fancy for a 302 haha.