weird clutch issue

blkbomber

New Member
Joined
Aug 23, 2014
Messages
6
Reaction score
0
Guys I need your help, I installed a center force clutch with a new steeda clutch quadrant, firewall adjuster and new cable.
When the car is cold it shifts perfect but after about 5 miles the clutch is hard to engage and or disengage and when i press the clutch pedel in it makes a popping and creaking sound and is felt in the pedal. Sound is coming from pressure plate finger area. Any help would great thanks. Car is 94 gt 5.0 with a promotion t-5
 

RichV

Well-Known Member
Joined
May 6, 2012
Messages
4,230
Reaction score
248
Location
CO
Maybe put your stock quadrant/cable in. Rule that out.

How long ago? Maybe get centerforce on the line. I bet they'll stand by everything. Make sure everything was installed per directions, the quadrants and fire wall adjusters can be tricky if not matched correctly with the right cable. But if it's a kit, it should all be matched.
 
OP
OP
B

blkbomber

New Member
Joined
Aug 23, 2014
Messages
6
Reaction score
0
Installed new fork and pivot when I installed the clutch. Will to get with center force and see if they had this issue before.
 
OP
OP
B

blkbomber

New Member
Joined
Aug 23, 2014
Messages
6
Reaction score
0
Ok guys pulled the trans back out and inspected everything found a small crack on the throw out bearing which when it is hot will expand and cause it to hang up. Put in a new bearing and shifts like butter. Not sure how it cracked never seen one do that , not sure if it had the crack in it before the install or it happen during install.
 
OP
OP
B

blkbomber

New Member
Joined
Aug 23, 2014
Messages
6
Reaction score
0
Ok guys pulled the trans back out and inspected everything found a small crack on the throw out bearing which when it is hot will expand and cause it to hang up. Put in a new bearing and shifts like butter. Not sure how it cracked never seen one do that , not sure if it had the crack in it before the install or it happen during install.
 

tykempster

Member
Joined
Feb 25, 2014
Messages
103
Reaction score
0
I have the exact issue you're talking about, but my TOB squeals too. Less than 5k miles on it. Sometimes the clutch will feel better for a few shifts but then goes back to the groaning and popping...really not looking forward to pulling the tranny.
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
28,333
Reaction score
3,877
Location
Evansville Indiana
I just got my exedy stage 3 clutch and while it comes with a TOB I got a ford racing after hearing all the others were crap.
 

tykempster

Member
Joined
Feb 25, 2014
Messages
103
Reaction score
0
I'm beginning to think the Ford racing one is the way to go. RAM said they usually didn't have many TOB problems and that they'd send another for free, but I'm not sure if I want to take the risk again.
 
OP
OP
B

blkbomber

New Member
Joined
Aug 23, 2014
Messages
6
Reaction score
0
Mine was a Ford racing tob just make sure inspect it closely before install.
 
OP
OP
B

blkbomber

New Member
Joined
Aug 23, 2014
Messages
6
Reaction score
0
Make sure to check the bearing shaft it can May be gouged causing the bearing stick and hang
 

Latest posts

Forum statistics

Threads
75,170
Messages
1,456,895
Members
13,700
Latest member
Ronnied

Members online

Top