What Did You Do To Your Car Today?

96blak54

Legend
Joined
Feb 21, 2011
Messages
8,032
Reaction score
1,297
Location
Ky
I can vouch for vtchopperdude. Yes! Royal purple in our manual transmissions is gold! You will feel a difference going from something like store brand fluids to the royal purple.
 

tmwsccsh

Active Member
Joined
Jun 16, 2019
Messages
333
Reaction score
260
Location
England
Thank you!

Still not as good as the wood in the MR2 I posted a couple of years back...

TMW
 
Last edited:

tmwsccsh

Active Member
Joined
Jun 16, 2019
Messages
333
Reaction score
260
Location
England
Funny you say Pick Up Truck.

I passed one not 200 yards from home and thought "got to get me one of them". And they are rare over here in the UK.

TMW

PS - as a side-note, looking at the picture again, my front bush could do with a trim...
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
28,004
Reaction score
3,751
Location
Evansville Indiana
I got the alignment done today and its finally driving straight now. Of course then on the way back I started to hear some noises from the brakes that I will be checking out but I knew its only a matter of time before I needed to fix something else. On the way back a challenger pulled up next. We were in traffic so we couldn't do anything fun but he gave it a rev, and I responded by hitting the loud button and revving her up. We did one small pull in 4rth gear but he had dealer plates and I am on a new tranny so I don't think either of us were all out but it was fun, he didn't dust me at the very least and I got a thumbs up when I rolled past him at the light.
 

white95

Apex Junky
Admin
Joined
Dec 30, 2007
Messages
17,682
Reaction score
4,356
Location
Prairieville, LA
Finished the sway bar install and added shims to the tail shaft to bring it up 1.5°…

Going to finish the roll bar install and test drive it tomorrow…

Clock is ticking!!

CB4F8481-29E9-4EC0-BAC6-0954F63166F3.jpeg
 

PinkieT

Well-Known Member
Joined
Jun 22, 2015
Messages
1,974
Reaction score
612
Location
Cleveland
New complete differential with ring and pinion in my wife's pink 98 is in the cards... :-(
 

Attachments

  • broken shim.jpg
    broken shim.jpg
    8.8 KB · Views: 6
  • dented diff, spring missing.jpg
    dented diff, spring missing.jpg
    10.1 KB · Views: 5
  • shards.jpg
    shards.jpg
    8.9 KB · Views: 5
  • pinion.jpg
    pinion.jpg
    15.1 KB · Views: 6

PinkieT

Well-Known Member
Joined
Jun 22, 2015
Messages
1,974
Reaction score
612
Location
Cleveland
how did she do that? Just driving along and?
No idea. She cruises, no burnouts or stoplight drags. We heard a noise start in the back a few months ago. Sounded like a wheel bearing to me. I took it to a local shop who pulled the fill plug on the differential housing as part of the diagnosis process and found a lot of shrapnel. Took it to a specialty shop who took it apart and found this mess. New ring and pinion, new carrier, basically salvaging the axles and little else.
 

RAU03MACH

Well-Known Member
Joined
Apr 23, 2019
Messages
3,244
Reaction score
2,611
Location
NEW MEXICO
Is that a standard or automatic
If standard does she ride around in 3 rd 4th gear mostly
My ex use to do that 3rd gear every where
My trans went through hell and it definitely did not do any good on the rear end
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
28,004
Reaction score
3,751
Location
Evansville Indiana
I was going to make a joke that maybe she is hitting some LA style sideshows and not telling anyone till I realized that I am sure we would have seen a video of a pink SN doing donuts if she did.

I took mine for another drive today and hoped the gas gauge was wrong when I realized it was showing a 1/4 tank. Looks like I am almost getting 14 mpg but there was a fair amount of idle time in that. I am looking forward to taking some drives now and see what it can do mpg till the tranny is broke in, and after how bad I can make it :)
 

88stang88

Professional Lurker
Joined
Jun 2, 2012
Messages
183
Reaction score
186
Location
Granite City, IL
Rigged up a different mid-pipe setup. I had my original Catted X-pipe for stock manifolds and then a O/R X-pipe for a 99+newer car so the O2 sensors were in the wrong spot. Didn't have the hangar for the trans mount etc. Kind of created one working one from two that didn't fit correctly.

Also with the help of @Venompower I was able to sort out my vacuum lines and now have working vent air again!

Tuning session tomorrow.
 

Latest posts

Forum statistics

Threads
75,024
Messages
1,454,617
Members
13,638
Latest member
HybridLogan

Members online

No members online now.
Top