95 GT coolant issue

Discussion in 'The Garage' started by BigRed2k, Jan 30, 2007.

  1. BigRed2k

    BigRed2k New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Jan 29, 2007
    I noticed a small puddle under the right front bumper today. Seems like its coolant (very light pinkish color) I let the car idle for about 5 minutes and it would drip down at a rate of about 1 drop every 5 seconds.

    After idling for JUST 5 minutes I loosened the rad cap and coolant was already pouring out of it. Is this normal? I thought it only was supposed to expand like that when the engine was hot (atleast hotter than it would be idling for 5 minutes)

    Also the rad cap doesnt seem to come completely off!?! The coolant overflow isnt near the fill line but im assuming it should only be that high when the engine is hot.

    I'm at far from being a gearhead (yet) and I just bought the car so im learning ALLLLL about this stuff from scratch =) I'll break out the chiltons today but its too damn cold to be doing work on a car here.

    Any ideas?
     
  2. Lightning Struck

    Lightning Struck Legend

    Messages:
    23,204
    Likes Received:
    2
    Joined:
    Jan 12, 2006
    have you added water or coolant to your system recently? Maybe you over filled it ???
     
  3. Suspect

    Suspect Well-Known Member

    Messages:
    2,776
    Likes Received:
    1
    Joined:
    Jan 13, 2006
    Location:
    ATL
    did u look under and see where its coming from? could be a leak from the upper hose or just a pinhole in the rad. also u should pick up a new cap. (its 16 psi)
     
  4. BigRed2k

    BigRed2k New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Jan 29, 2007
    Wasnt able to really investigate it much on my 15 minute break @ work today. How to do get the rad cap off? It seems like its secured with a roundhead screw or something? Do I just need to yank harder? I recall the 16psi rating being on the cap so I know its the right rating.
     
  5. Suspect

    Suspect Well-Known Member

    Messages:
    2,776
    Likes Received:
    1
    Joined:
    Jan 13, 2006
    Location:
    ATL
    not to be a smartass, but did u try pushing down then twisting it off?
     
  6. 97blackgt

    97blackgt Well-Known Member

    Messages:
    1,064
    Likes Received:
    0
    Joined:
    Dec 8, 2006
    in 5 minutes i would imagine 16 psi was built up in ur cooling system and therefore the cap turns off hard because the 16 psi is pushing on it. Maybe the slow leak was coming from your overflow? Maybe the upper radiator hose?
     
  7. BigRed2k

    BigRed2k New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Jan 29, 2007
    Ok I atleast know how to remove a radiator cap =) but atleast it was a good guess ;)

    Today after work I left and noticed my "check coolant level" light was on. Stopped at the 1st gas station (2 minutes away) and they didnt havnt coolant. Upon getting back in the car the light was off so I popped the hood and checked the coolant level. 16 psi builds up QUICK. The coolant level seemed to look fine. I know it expands when warm but the overflow was right under the "fill to" line so I put a little bit in and will watch it closely the rest of this week.

    I should be able to track the source of the leak this weekend. Hopefully its nothing major. In any case I will report back Saturday morning with an update and probably some questions.

    Thanks for the help!
     
  8. 95-stang

    95-stang Well-Known Member

    Messages:
    2,446
    Likes Received:
    0
    Joined:
    Jan 6, 2007
    Even though my car had only 50 thou on it and is clean everywhere, the rad burst on it, not bigtime,
    but it used to dribble a bit here and there, nice and easy to replace, just had to import one.
     
  9. uncltrvlnmatt

    uncltrvlnmatt Legend

    Messages:
    14,939
    Likes Received:
    28
    Joined:
    Apr 8, 2006
    Location:
    Pa.
    If the engine is cold when you start it up, it will not get hot enough in 5 minutes to build 16psi. Sounds like you could have a compression leak.

    My thought with the little info available.
     
  10. 97blackgt

    97blackgt Well-Known Member

    Messages:
    1,064
    Likes Received:
    0
    Joined:
    Dec 8, 2006
    Also could possibly be the water pump leaking though the weep hole?
     
  11. BigRed2k

    BigRed2k New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Jan 29, 2007
    It seems the leak has stopped (for now atleast) Drove around looking for someone to pass me for state inspection for hours yesterday (Cant pass b/c of tinted strip on windshield) and it didn't leak once. I'll still keep an eye on it.