Surging Idle

Noto

New Member
Joined
Sep 27, 2014
Messages
14
Reaction score
0
I have a strange idle issue that I cant seem to find someone else having. My car starts and idles fine for around 2-3 minutes. Then it will start to surge and want to stall. Suddenly the cel comes on and it clears up and idles at 850 fairly smoothly. Also on warmed up restarts it will surge for a minute or so then throws a cel and idles normal. What could this be? Could it be my egr delete?
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
28,301
Reaction score
3,859
Location
Evansville Indiana
welcome to the forum. I assume its on the car listed in your sig? Reading through all the mods, have you had a tune done on it?
 

CC'S95GT

Post Whore
Joined
Apr 19, 2008
Messages
10,738
Reaction score
172
Location
Hampton ,Ga.
Have you pulled codes to make sure it's not something other than your EGR delete? You can DIY with a paperclip.

And as stated above. Is it dyno tuned?
 

Noto

New Member
Joined
Sep 27, 2014
Messages
14
Reaction score
0
I havent had it tuned yet. I have an sct on the way from am. I pulled codes and got 116, 23, and 27. I replaced ect and 116 went away. tested tps with engine off. Had .92 closed and had a smooth voltage transition to 4.92 when working the throttle. Smoke tested for vac leaks and the only small one I had was from the throttle body itself in the shaft. Im still stumped but having fun with it
 

Addermk2

Well-Known Member
Joined
Mar 7, 2006
Messages
2,526
Reaction score
48
I havent had it tuned yet. I have an sct on the way from am.

It's too bad that you wasted your money on one of their terrible tunes. When you're ready to get something better on that chip, LMK. I fix the American Muscle "Bama Tunes" pretty much every week.

Could it be my egr delete?

Usually.
 

Noto

New Member
Joined
Sep 27, 2014
Messages
14
Reaction score
0
It's too bad that you wasted your money on one of their terrible tunes. When you're ready to get something better on that chip, LMK. I fix the American Muscle "Bama Tunes" pretty much every week.

Ive heard mixed reviews about their tunes. I figured that I would only save $60 by buying the chip with no tunes on it. This way hopefully it will be a little more driveable till I can take it to the dyno.
 

NXcoupe

Well-Known Member
Joined
Aug 16, 2009
Messages
1,301
Reaction score
12
That's the first thought that crossed my mind was O2 issue and since you have long tubes, that's the issue for sure. I would have whoever tunes it turn off the 02 sensors since they just get confused with the longtubes.
 

Noto

New Member
Joined
Sep 27, 2014
Messages
14
Reaction score
0
That's the first thought that crossed my mind was O2 issue and since you have long tubes, that's the issue for sure. I would have whoever tunes it turn off the 02 sensors since they just get confused with the longtubes.
02 sensor spots are plugged with faux type plugs. Came like that. No wires running to them
 

Latest posts

Forum statistics

Threads
75,161
Messages
1,456,658
Members
13,698
Latest member
rickedeke17

Members online

Top