Whistling noise on cold engine

GTamas

Active Member
Joined
Apr 17, 2023
Messages
422
Reaction score
440
Location
Austria
Hi everyone,
My 94 GT started recently to do a whistling or whining noise when starting the engine cold. It does it only at specific rpms, around 2000 and 1100. The pitch also changes slightly with the rpm. It's coming from the engine bay and it's not super loud, but easily hearable. I have the feeling it has to do something with air currents. Sounds like blowing a whistle.
It goes away when the engine is warmed up.

There's a video below:

I did not yet have the chance to locate the source because it does not do it at idle and I did not have anyone around to set the rpm while I look for the source.

Do you have any idea what I should look for?
Engine is stock with only a K&N filter inside the stock air box.
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
32,961
Reaction score
5,773
Location
Evansville Indiana
check the pcv behind the lower intake to ensure it is in tight. I had the same kind of noise that drove me nuts for a while because no matter what side of the motor I was on, it sounded like it was on the other side.
 

cobrajeff96

Well-Known Member
Joined
Feb 1, 2022
Messages
1,756
Reaction score
1,651
Location
Germany
Might actually be the throwout bearing.

Noises are especially difficult to pinpoint in a giant metal echo chamber.
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
32,961
Reaction score
5,773
Location
Evansville Indiana
that pcv whistle drove me nuts going back and forth. I was starting to think it was moving every time I moved.
 
OP
OP
GTamas

GTamas

Active Member
Joined
Apr 17, 2023
Messages
422
Reaction score
440
Location
Austria
I hope I will get the chance to do a smoke leak test soon.
 
OP
OP
GTamas

GTamas

Active Member
Joined
Apr 17, 2023
Messages
422
Reaction score
440
Location
Austria
I found out today that my power steering fluid is way overdue for a change and level is low. (embarassed that I didn't check it earlier)
I noticed today, that the whistling sound is coming from around the left front of the engine. I'm suspecting the pump is making it. I will drain the fluid and refill, let's see how much it helps.
20240325_203218.jpg
20240325_203223.jpg
 

cobrajeff96

Well-Known Member
Joined
Feb 1, 2022
Messages
1,756
Reaction score
1,651
Location
Germany
Sounds legit. My setup would groan in the cold (like very cold around 0 or -5*C) and would go quiet within seconds. New pump and new fluid too.
 

ruquikr

New Member
Joined
Jan 9, 2024
Messages
10
Reaction score
22
I'm hearing the same thing on mine, and my PS fluid looks horrible. Looks like that's another item on the list to take care of. Also noticed my smog pump chirping when it's cold, and will now make a faint grinding noise when warmed up. I'm guessing that's on it's way out too.
 

Latest posts

Forum statistics

Threads
77,655
Messages
1,506,558
Members
15,084
Latest member
CBR51Stang

Members online

Top