98 Cobra front brake Rattling issues.

Discussion in 'The Garage' started by 9838stang, Oct 19, 2014.

  1. 9838stang

    9838stang Well-Known Member

    Messages:
    2,539
    Likes Received:
    141
    Joined:
    Sep 13, 2010
    Location:
    Minneapolis,MN
    I have installed 4 sets of pads on these calipers since i put them on last summer, 2013. I ran the stock pads, stock rotors and stock lines. After driving with them on for about 3,000 miles, the drivers side caliper mount rattled loose and wrecked the pads. I tightend down everything and double checked them, and installed a set of mid grade o'reillys pads. I installed the pads with the stock hardware and ran them. they worked great for 4,000 to 5,000 miles. They started to rattle. I looked them over to see what was going on, and it looked like one of the springs that held pads the inplace broke. In turn, the little spring clips that hold the pad in the caliper broke off. So I put new pads and caliper hardware in place. And used the car for about 1000 too 2000 miles. Put in storage and got it out the following spring. I drove it out of storage and drove it for another 2000 to 3000 miles and noticed the same sound. I bought some new pads, pad hardware kit from napa this time and some MM ss line for the front and everything worked great for another 1500 to 2000 miles. I still am running the same rubble bumpers in the clips.

    And idea as to why this is happening... Do i keep getting the crappy pads .... As soon, push down on the pads, the sound goes away for a while until i hit a series of bumps... and ideas...
     
  2. 9838stang

    9838stang Well-Known Member

    Messages:
    2,539
    Likes Received:
    141
    Joined:
    Sep 13, 2010
    Location:
    Minneapolis,MN
    I should point out, I do use them. Sometime light, and that is when the sounds tend to surface, but other times when i am on them hard and use them hard there is no sound until they somewhat cool off.... and then they rattle

    [​IMG]
     
  3. g36 monkey

    g36 monkey Moderator Staff SN95 Supporter

    Messages:
    14,057
    Likes Received:
    539
    Joined:
    Nov 15, 2008
    Location:
    Orlando, Fl
    Sounds like your anti rattle clips are bad, though you've made it sound like you changed them a number of times. But the symptoms are basically exactly what my car was with no clips at all
     
  4. 9838stang

    9838stang Well-Known Member

    Messages:
    2,539
    Likes Received:
    141
    Joined:
    Sep 13, 2010
    Location:
    Minneapolis,MN
    I replaced them twice. Still using the rubber stock piece though, and use new slid pins with new washers and clips
     
  5. ttocs

    ttocs Legend

    Messages:
    25,405
    Likes Received:
    2,438
    Joined:
    Oct 9, 2009
    Location:
    Evansville Indiana
    little duct tape would fix it.
     
  6. 9838stang

    9838stang Well-Known Member

    Messages:
    2,539
    Likes Received:
    141
    Joined:
    Sep 13, 2010
    Location:
    Minneapolis,MN
    chrome or colored?
     
  7. 9838stang

    9838stang Well-Known Member

    Messages:
    2,539
    Likes Received:
    141
    Joined:
    Sep 13, 2010
    Location:
    Minneapolis,MN
    Looks light i might have it figured out... the past pads had the clips that hold them into the caliper brake off, and they would rattle around. But this time the springs/sliders didnt have any tension in them and would allow the calipers to move around. Got a new hardware kit and no more rattling.

    thanks all! We will see how long this works out I went for a 30 minute drive, on a bumpy road which kills me to do it, but i did and now noise!