Chugging Oil...

Discussion in '96-04 - 2V Specific' started by st4ng07, May 15, 2007.

  1. st4ng07

    st4ng07 New Member

    Messages:
    38
    Likes Received:
    0
    Joined:
    Jan 3, 2007
    Since my last oil change my car has really started chugging oil....like 1 quart to 1 1/2 quarts every 600 miles, just really frustrated and now my rear rims are starting to leak since the last person be4 me beat the crap out of them..I already tried everything to keep them sealed. I just had to spend 1100$ of bodywork cause of a stupid person who didnt have insurance. So now im broke.
     
  2. DropTopPony

    DropTopPony Administrator Staff Member Admin SN95 Supporter

    Messages:
    15,342
    Likes Received:
    119
    Joined:
    Jan 12, 2006
    Location:
    South Jersey
    Did you use a thinner oil on this last oil change? Maybe its time for some valve seal replacements.
     
  3. 19inchmustang

    19inchmustang New Member

    Messages:
    61
    Likes Received:
    0
    Joined:
    May 1, 2007
    ON YOUR RIMS PUT BEAD SEALER SHAT SHOULD HOLD O0
     
  4. voidfinger

    voidfinger Well-Known Member

    Messages:
    3,880
    Likes Received:
    0
    Joined:
    Dec 16, 2006
    I don't know, i'm in the same boat. My last oil change my car used 1 to 1 1/2 quarts in under 1000 miles. It never used any before hand.

    Drop so you think it is the valve seals? It seems unlikely that the car would start burning that much that fast right?

    i think ill do a compression test this weekend.... What should the compression test read on hot and cold....sorry for the change of topic...
     
  5. 68mustang5.0

    68mustang5.0 Active Member

    Messages:
    409
    Likes Received:
    0
    Joined:
    Feb 19, 2007
    Um, what does your answer have to do with his car chugging oil? :nonono: :blah2: