Engine codes 176 542 543 and 556 help

Discussion in '94-95 5.0 - Specific' started by shadowblack5.0, May 13, 2016.

  1. shadowblack5.0

    shadowblack5.0 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    May 13, 2016
    I finally was able to pull some codes on my 94 gt,l. I got 176 lean condition, 542 fuel pump open circuit pcm to ground, 543 fuel pump open circuit batter to PCM, and 556 fuel pump relay primary circuit failure. Also got 211 profile ignition pickup erratic.

    Has anyone encountered these codes and have advice on how to fix them? Or should I just replace the wires in the circuit and the relay in the CCRM?

    Also possibly unrelated I got 542 open vehicle speed sensor circuit. My speedo is 5mph slow and odometer isn't working I think it's the gear. But also got 212 no tach input to processor.


    Sent from my iPhone using Tapatalk


    Sent from my iPhone using Tapatalk
     
  2. Magic

    Magic Well-Known Member

    Messages:
    1,639
    Likes Received:
    31
    Joined:
    May 3, 2007
    Location:
    Some time zone
    Swap out the CCRM for a good working one to verify the problem, or you can take it apart and fix it.
    Relay info here:
    http://www.sn95forums.com/showthread.php?42710-95-mustang-gt-ccrm-fuel-pump-relay-replacement

    Speedo issue, check the speedo sensor/wiring/pigtail.
    Odometer most likely the gears, as it is a very common problem. 1

    Code 176, is lean on bank 2, drivers side. Could be an exhaust leak or bad O2 sensor. Also check the wiring there as well. The trans harness and 02 harness branch out from the same bulk head. Might even be some corroded or torn wiring.