Heater only works on high

dcolli10

New Member
Joined
Apr 26, 2023
Messages
13
Reaction score
3
Need help diagnosing a blower motor issues. During my motor swap the body harness was off the car on the Left side of the engine bay. When hooking it back up. It only worked on high. After tightening all connections and grounds. A few weren’t on properly. I had the function of every speed. Low, mid and high speed. Now that the car is running it is back to just high only. Anyone know how the blower motor is wired. Does the high setting get power from a different source from the lower speed settings.
tried searching but couldn’t find anything on this subject.
 

07GtS197

Well-Known Member
Joined
Mar 16, 2015
Messages
2,635
Reaction score
996
Location
Fort Myers, Fl
They get their power from the same source. That’s usually how they fail though, nothing but high speed.
 

TTSaleen

Active Member
Joined
Aug 12, 2011
Messages
759
Reaction score
313
Location
NC
Could be a coincidence but actually be the resistor for the fan.
Here's a video on that and how to fix it.
 

1996GTNA

New Member
Joined
May 6, 2020
Messages
4
Reaction score
1
Could be a coincidence but actually be the resistor for the fan.
Here's a video on that and how to fix it.
Try replacing the resistor as shown in his video. My 96 GT blower fan quit working except on high. I was ready to replace the blower switch and ran across the resistor fix. Doesn't cost much and pretty easy to get to.
 

Wood's 5.0

Member
Joined
Sep 27, 2016
Messages
188
Reaction score
102
Location
South Carolina
Remembering my days working in the Ford service department, blower motor speed problems were, more often than not, a result of a faulty blower motor resistor.
 

Vincent

New Member
Joined
Jul 4, 2023
Messages
6
Reaction score
3
Need help diagnosing a blower motor issues. During my motor swap the body harness was off the car on the Left side of the engine bay. When hooking it back up. It only worked on high. After tightening all connections and grounds. A few weren’t on properly. I had the function of every speed. Low, mid and high speed. Now that the car is running it is back to just high only. Anyone know how the blower motor is wired. Does the high setting get power from a different source from the lower speed settings.
tried searching but couldn’t find anything on this subject.
I think there's a resistor that can go bad. Years ago mine was replaced but i forgot where it is.
 

Forum statistics

Threads
77,361
Messages
1,500,248
Members
14,855
Latest member
mseal13

Members online

Top