Help Voltage probelm

Demolisher

Active Member
Joined
Aug 14, 2006
Messages
261
Reaction score
0
after i installed my HID's my volate went down i mean ill have the aircon running my system on and my hid's and the voltage needle will be on N and if its hot out side it will wanna turn off ill have to put my foot on the brake and give it gas so the rpms can stay high my thoguht is its the alternator i just need somehelp im having diffrent problems lalty ur alls help would be appricated :dunno:
 

ryclef331

Well-Known Member
Joined
Jan 20, 2006
Messages
2,913
Reaction score
11
Do you run underdrive pullies? Do you have a system?
 
OP
OP
D

Demolisher

Active Member
Joined
Aug 14, 2006
Messages
261
Reaction score
0
yah i have a system and i just have a crank pulley but i had been running all this and once i got my hid's i t hink it just shot it ! :gtfo: lol like everyitme i turn something on the volate needle gets lower and lower
 

ryclef331

Well-Known Member
Joined
Jan 20, 2006
Messages
2,913
Reaction score
11
I suggest you put the stock pulley back on there. HIDs, A/C, AND a SYSTEM....thats ALOT of current even for our stock alternators.
 
OP
OP
D

Demolisher

Active Member
Joined
Aug 14, 2006
Messages
261
Reaction score
0
well the problem is i dont got the stock pully i sold it u dont think i need a new alternator i mean comon the car is a 95 and what amps do i look for in an alternatior?
 

Latest posts

Forum statistics

Threads
77,663
Messages
1,506,730
Members
15,089
Latest member
bturner425

Members online

Top