HELP!!!

Discussion in '94-95 5.0 - Specific' started by bigslim00, May 22, 2014.

  1. bigslim00

    bigslim00 New Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Nov 30, 2013
    Location:
    GA
    My 95 mustang gt has a rough idle and slight hesitation when accelerating. The fan also run continuously when car is running but I think that is another problem. I ran tests and the codes 172, 176, 181, 189 and 543 came up. I already changed the 02 sensors. My guess is the fuel pump or fuel filter. Maybe even bad injectors. Any suggestions?
     
  2. MustangChris

    MustangChris Legend Retired Staff SN95 Supporter

    Messages:
    27,425
    Likes Received:
    873
    Joined:
    Aug 20, 2008
    Location:
    Aurora, CO
    Clean your mass air flow and get back to us.
    Additionally, while you're there clean your intake air temperature sensor with the same MAF cleaner spray.

    I'm struggling to find those OBD I codes right now, so I'm not 100% on those.
     
  3. bigslim00

    bigslim00 New Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Nov 30, 2013
    Location:
    GA
    I already cleaned the maf
     
  4. toyman

    toyman Active Member

    Messages:
    874
    Likes Received:
    9
    Joined:
    Aug 25, 2008
    They are in a sticky at the top of this section.
     
  5. CC'S95GT

    CC'S95GT Legend

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    when was the last time the plugs, wires, cap, rotor, fuel filter, and pcv valve was changed?

    BTW where in Ga?