I've been having this weird issue lately.

Discussion in '96-04 - 2V Specific' started by 96BugbearGT, Jan 7, 2014.

  1. 96BugbearGT

    96BugbearGT Well-Known Member

    Messages:
    120
    Likes Received:
    2
    Joined:
    Apr 14, 2013
    Location:
    Lancaster, CA
    Alright, every now and again after engine braking (let's say, getting off of the freeway. Engine brake in 3rd gear) I push the clutch in and my car dies. Never any other time. It only happens after engine braking. 3rd or 2nd gear. It happened awhile ago. I cleaned my idle air control valve and it went away until I just recently. Now it is very inconsistent. It'll do it mainly after freeway/highway runs. Any ideas?

    My car is a 96 GT, PI cams, many other bolt ons and the Bama handheld. Thanks in advance guys. This issue has almost got me in a couple accidents.
     
  2. Willis_98GT

    Willis_98GT Well-Known Member

    Messages:
    3,180
    Likes Received:
    24
    Joined:
    Jun 18, 2007
    Location:
    DFW Texas
    Just do a run-through under your hood.

    Check all your vacuum lines and connections. sometimes a loose or brittle hose can let enough air escape can cause a stall. My car used to do the same thing.

    have you messed with your idle speed on your tuner? sometimes if its too low the IAC wont catch it right away before its too late. Remember pi cams are bigger then the stockers
     
  3. 96BugbearGT

    96BugbearGT Well-Known Member

    Messages:
    120
    Likes Received:
    2
    Joined:
    Apr 14, 2013
    Location:
    Lancaster, CA
    The tune is set for the PI cams, but I did adjust the neutral idle speed and haven't had the issue again. So, fingers are crossed. Thanks man.

    Sent from my LG-LS980 using Tapatalk
     
  4. 96BugbearGT

    96BugbearGT Well-Known Member

    Messages:
    120
    Likes Received:
    2
    Joined:
    Apr 14, 2013
    Location:
    Lancaster, CA
    Well, after I adjusted my idle speed. I thought I had solved the problem. Nope. Now it only happens after a short freeway drive (about 5 miles) never while city driving anymore. Only 3rd gear while braking. Pushed the clutch in and it died. Still lost. No time until Sunday to go through the lines until Sunday when I do my front hub assembly.
     
  5. Willis_98GT

    Willis_98GT Well-Known Member

    Messages:
    3,180
    Likes Received:
    24
    Joined:
    Jun 18, 2007
    Location:
    DFW Texas
    Man that's bizarre.

    So like, you're just crusing and its just third gear that you clutch out and it dies?

    2-2500rpm to idle?
     
  6. 96blak54

    96blak54 Well-Known Member

    Messages:
    6,110
    Likes Received:
    11
    Joined:
    Feb 21, 2011
    Location:
    Ky
    Check all speed censors