What to do about gauge cluster??

Gabrielw94106

New Member
Joined
Apr 1, 2023
Messages
7
Reaction score
10
Hey everyone, I got my car within the last year and when i bought it the tach ,odometer , lights, and temp gauge aren’t working on the gauge cluster. The fuel gauge won’t show full and drops towards empty faster than it would be. I think that’s the float valve though. It drives fine the only real reason i wanna get a new one is for the temperature gauge to work and for the lights to work on it so I’m able to see at night. I tried switching the lights off a pick n pull cluster that didn’t work. Thank you all for any advice you’re able to offer.
 

Attachments

  • C005C3C1-08B7-42E0-B2F4-22B0853B50A0.png
    C005C3C1-08B7-42E0-B2F4-22B0853B50A0.png
    627 KB · Views: 5

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
32,202
Reaction score
5,493
Location
Evansville Indiana
so it sounds like you have had the gauges out of the dash? If so then take them out again and give a close inspection to the gauge pod side of the harness connection. If you looked at the way it is made they have some large copper traces on a semi-soft plastic and the traces that make the connection at the harness can lift up and slip over to touch the trace next to it and cause all kinds of strange problems. Fixing it is as simple as gluing the trace back in place and carefully reinstalling the pod.
 
OP
OP
G

Gabrielw94106

New Member
Joined
Apr 1, 2023
Messages
7
Reaction score
10
so it sounds like you have had the gauges out of the dash? If so then take them out again and give a close inspection to the gauge pod side of the harness connection. If you looked at the way it is made they have some large copper traces on a semi-soft plastic and the traces that make the connection at the harness can lift up and slip over to touch the trace next to it and cause all kinds of strange problems. Fixing it is as simple as gluing the trace back in place and carefully reinstalling the pod.
Ill take a peak at it and get back to you see whats up if not I might just have to send it in for repairs. Yes I have had it out of the car to try and put new bulbs in. I hadn’t checked any connections ill do that now
 
Last edited:

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
32,202
Reaction score
5,493
Location
Evansville Indiana
as for the lighting, if you put leds in there you have to put them in the correct way with the + and the - on the rights sides or they will not light up. If you have a dead spot try taking the light out, flipping it 180 degrees and then putting it back in
 

BHernandez

New Member
Joined
Mar 7, 2022
Messages
77
Reaction score
36
Hey everyone, I got my car within the last year and when i bought it the tach ,odometer , lights, and temp gauge aren’t working on the gauge cluster. The fuel gauge won’t show full and drops towards empty faster than it would be. I think that’s the float valve though. It drives fine the only real reason i wanna get a new one is for the temperature gauge to work and for the lights to work on it so I’m able to see at night. I tried switching the lights off a pick n pull cluster that didn’t work. Thank you all for any advice you’re able to offer.
What year is it? I've got a spare 97 Cobra cluster for sale. Complete and in good working order with approximately 173k on the odometer. $250 plus shipping and it's yours.
 
OP
OP
G

Gabrielw94106

New Member
Joined
Apr 1, 2023
Messages
7
Reaction score
10
What year is it? I've got a spare 97 Cobra cluster for sale. Complete and in good working order with approximately 173k on the odometer. $250 plus shipping and it's yours.
Ive got a 98 gt within the same years but im gonna see if I can fix my current one. Ill see if youve still got it up if i can’t fix it up
 
OP
OP
G

Gabrielw94106

New Member
Joined
Apr 1, 2023
Messages
7
Reaction score
10
Mark had let me know that with the problems on my cluster it may be bad wiring to the cluster itself. Ill have to start diagnosing that before he says to send it in. Either way itll be a project yall as this car tends to want to be.
 

Latest posts

Forum statistics

Threads
77,354
Messages
1,499,903
Members
14,843
Latest member
stanginator1

Members online

Top