95 gt problem

Discussion in '94-95 5.0 - Specific' started by 5.0, Mar 22, 2014.

  1. 5.0

    5.0 New Member

    Messages:
    60
    Likes Received:
    0
    Joined:
    Mar 22, 2014
    Location:
    Nc
    I recently bought a 95 gt with 160,000 miles. And it leaks a little oil from the rear main, and when it gets only about a half quart low it starts missing or jerking especially in 5th gear, and when I put about a half quart too much in it also misses or jerks and has some blue smoke out driver tailpipe. But if I have the oil level right at the full line it runs perfect with no smoke until it gets low again. What's going on?
     
  2. RSB95

    RSB95 New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Mar 3, 2014
    Wow never heard of such...
     
  3. CC'S95GT

    CC'S95GT Legend

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    when was the last time the PCV was changed?
    The 2 things shouldn't have anything to with one another. but stranger things have happened.
     
  4. Win

    Win Legend

    Messages:
    9,514
    Likes Received:
    8
    Joined:
    Nov 20, 2006
    Location:
    Kennesaw, Ga
    I'm gonna say check all your plugs and rotor cap and rotor?
     
  5. 5.0

    5.0 New Member

    Messages:
    60
    Likes Received:
    0
    Joined:
    Mar 22, 2014
    Location:
    Nc
    I know where the pcv is located. But when I take it off what should I be looking for? And to clarify some, when either too much or too little oil. engine is not actually missing, it just runs kinda crappy and has less power and jerks at lower rpms
     
  6. 5.0

    5.0 New Member

    Messages:
    60
    Likes Received:
    0
    Joined:
    Mar 22, 2014
    Location:
    Nc
    Also I'm sure this has nothing to do with it but mods are- 4:10 gears, cold air intake, smog pump delete, under drive pulleys, 3 inch exhaust with h pipe, and it sounds like it might have a mild cam, not sure though
     
  7. RichV

    RichV Well-Known Member

    Messages:
    4,227
    Likes Received:
    247
    Joined:
    May 6, 2012
    Location:
    CO
    This the goofiest one yet.

    As suggested, PCV and ignition. I would also make sure your engine ground is 100% and check the vacuum lines.

    Does it have any other issues? Electrical, running/driving, any weird noises? Sounds like it has a cam? Not sure why someone would put a cam on stock headed/intake 5.0, so check the vacuum lines for sure.
     
  8. 5.0

    5.0 New Member

    Messages:
    60
    Likes Received:
    0
    Joined:
    Mar 22, 2014
    Location:
    Nc
    Ok about to change pcv valve, no other issues, but now it is running bad even with correct amount of oil. It's not running real bad and you don't really even notice is until you put it in 5th gear in low rpms, it jerks and shakes until about 2000 rpm
     
  9. RSB95

    RSB95 New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Mar 3, 2014
    Sounds like the dizzy to me
     
  10. RichV

    RichV Well-Known Member

    Messages:
    4,227
    Likes Received:
    247
    Joined:
    May 6, 2012
    Location:
    CO
    I would check the ignition system as well. Plugs, wires, cap/rotor.
     
  11. 5.0

    5.0 New Member

    Messages:
    60
    Likes Received:
    0
    Joined:
    Mar 22, 2014
    Location:
    Nc
    UPDATE! I changed the pcv valve and filter, both were in bad shape, the valve wasn't even in there tight jested lifted right out, filter was nasty. Also the rotor cap was very corroded so I wire brushed all components, and I changed the oil with 10w 30 castrol high mileage, and the went for a drive, it started off driving a little better and after about 15 minuted of driving it started running perfect. And I drove it about an hour more and still running smooth and perfect, what does this tell you???
     
  12. CC'S95GT

    CC'S95GT Legend

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    I'm thinking the the PCV filter was clogged and was causing excess crank case pressure. you'll oil leak should be less now too.
    I think it's related to your rough running too.

    Don't know what the low oil level has to do with it though.
     
  13. 5.0

    5.0 New Member

    Messages:
    60
    Likes Received:
    0
    Joined:
    Mar 22, 2014
    Location:
    Nc
    UPDATE! Ok so this morning when I drive my car it starts running bad again, is I decide to change the sparks plugs, wires, rotor and cap, and then I find the real problem. One of the spark plugs was corroded and has crap baked on it and so half the time it wasn't even firing. Replaced and wow the power of all 8 cylinders! Running the smoothest ever with lots if power, thank you all for your imput