Alternator not charging

5.0Dell

New Member
Joined
Sep 7, 2021
Messages
11
Reaction score
2
I recently bought a 95 Gt and for some reason the alternator didn’t charge. After looking online I see that some people either replaced the gauge cluster (I did but no change) or take the green wire and tie it into a 12v source (I tied it into the low coolant reservoir wire and it’s charging). Is my current wiring fine or do I need to find another 12v source. As stated the car is charging and I do drive it. Btw the car has a battery relocation kit.
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
32,593
Reaction score
5,644
Location
Evansville Indiana
have you checked any fuses? If not start simple and dig in there. Don't bother with your manual it takes less time to pull and inspect each fuse and then we can be sure it is not one of those.
 
OP
OP
5.0Dell

5.0Dell

New Member
Joined
Sep 7, 2021
Messages
11
Reaction score
2
I checked all the fuses and they are good!
 

Addermk2

Well-Known Member
Joined
Mar 7, 2006
Messages
2,534
Reaction score
55
If you ran the green wire from the Alt, to 12v, and it began charging... then:

Inspect fuse #18 in the fuse panel under the drivers knee bolster.
Check wire continuity from the fuse, out to the alt plug. The wire also passes through the instrument cluster, to the battery warning light. Verify that the 500ohm resistor on the rear of the cluster is still good (I had it fail and needed to be replaced).
 

Forum statistics

Threads
77,486
Messages
1,503,531
Members
14,956
Latest member
Tharp3

Staff online

Top