O/R midpipe? o2 sensors

Fets

Post Whore
Joined
Jul 10, 2006
Messages
11,013
Reaction score
2
I dont have any on mine but my MIL light is on. I heard some people have problems with the MIL Eliminators. I heard they dont turn the light off, but I dunno. I'd like to know also
 

blackfang

Active Member
Joined
Jan 12, 2006
Messages
462
Reaction score
2
silversol said:
i also heard that once your mil light comes on it's a bitch to turn off and your car goes into "safe mode" and loses power
The front o2 sensors can cause it to go into open loop where it adjusts the fuel trims to a higher percent to compensate for the inability to read the air fuel. That will need a new sensor.

The rear o2's do nothing to cause that. Just get a tune and have them turned off. Both my cars have that.
Hope this helps
 

TxCobrA98

Legend
Joined
May 14, 2006
Messages
7,976
Reaction score
5
blackfang said:
silversol said:
i also heard that once your mil light comes on it's a bitch to turn off and your car goes into "safe mode" and loses power
The front o2 sensors can cause it to go into open loop where it adjusts the fuel trims to a higher percent to compensate for the inability to read the air fuel. That will need a new sensor.

The rear o2's do nothing to cause that. Just get a tune and have them turned off. Both my cars have that.
Hope this helps

hes right on the nose... just get a tune and have the code turned off and everything will be good. =D i need to get my car tuned badly!
 

Lightning Struck

Post Whore
Joined
Jan 12, 2006
Messages
23,204
Reaction score
2
blackfang said:
silversol said:
i also heard that once your mil light comes on it's a bitch to turn off and your car goes into "safe mode" and loses power
The front o2 sensors can cause it to go into open loop where it adjusts the fuel trims to a higher percent to compensate for the inability to read the air fuel. That will need a new sensor.

The rear o2's do nothing to cause that. Just get a tune and have them turned off. Both my cars have that.
Hope this helps

good answers
 

blackfang

Active Member
Joined
Jan 12, 2006
Messages
462
Reaction score
2
I had my front o2's go south on me. Sucks but I installed new ones.
 

Ender

Member
Joined
Aug 5, 2006
Messages
151
Reaction score
0
I had mil elims on for the short time that I ran an o/r H, and they worked fine. It's no big deal if you don't put them on though, it won't do anything except trip the check engine light.
 

blackfang

Active Member
Joined
Jan 12, 2006
Messages
462
Reaction score
2
silversol said:
won't the o2's plug into the aftermarket midpipe?
They will plug in just fine. Just use some anti sieze. However it is the connectors into the harness where you put the MIL eliminators. Otherwise it will set the CEL off.
 

Twista

Legend
Joined
Mar 7, 2006
Messages
6,042
Reaction score
76
silversol said:
so basically i have to have a tune to keep the cel off?

Just get the mils.. alot of people have them and they work.
 

Latest posts

Forum statistics

Threads
74,903
Messages
1,452,844
Members
13,580
Latest member
dpl255

Members online

Top