ongoing issues

Discussion in '94-95 5.0 - Specific' started by jwhisl, Aug 20, 2015.

  1. jwhisl

    jwhisl Active Member

    Messages:
    366
    Likes Received:
    3
    Joined:
    Dec 28, 2012
    Location:
    Oklahoma
    Ok so the car has been sitting for some time since my move to Oklahoma. I'm still having issues with fuel pressure. It wont hold any fuel pressure but plenty of fuel is making it to the rails. I'm wondering if it could be sensor related as aI still have a couple sensors not hooked up or if it could be the 87-93 fuel rails that are on my 94. I unhooked the main line up at the front of the car and stuck it into a water bottle. I cranked over the engine for 2-3 seconds and the water bottle was almost full of gas. I assume that I am just circulating all my gas right back to the tank after it goes through the rails. I can start it on ether and it will run very lean unless I unplug the maf then it dumps so much fuel I can smell it in the exhaust. That tells me that it can get the mount it needs but I need to figure out why it's not. I need help guys. Thanks
     
  2. CC'S95GT

    CC'S95GT Legend

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    Either buy or rent/borrow a pressure tester from the parts house. And a Haynes/Chilton manual.
    When you first hit the key (KOEO) the pressure should go to 40ish psi and hold there even after the pump shuts off. If it won't hold for an hour or bleeds off imediately you need a new regulator.
     
  3. 95opal

    95opal Well-Known Member

    Messages:
    2,030
    Likes Received:
    191
    Joined:
    Jun 21, 2007
    Sounds like a bad regulator but as CC said get a gauge on it before throwing money at it.