What is this??? Help!

Discussion in 'Drivetrain' started by anguem, Aug 14, 2014.

  1. anguem

    anguem New Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Aug 11, 2014
    [​IMG]

    My speedo went out and I poked my head under the car to make sure the vss was plugged in and noticed the rod hanging down. Also noticed a stud at the end of the tranny brace. What is it so I can fix it.
     
  2. anguem

    anguem New Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Aug 11, 2014
    Sorry wrong pic. [​IMG]
     
  3. SVTstang96

    SVTstang96 Well-Known Member

    Messages:
    1,262
    Likes Received:
    6
    Joined:
    Jan 26, 2010
    Location:
    Dubuque, Iowa
    Everything looks as it should be. The rod at the bottom hanging down is the exhaust hanger. You can see the rubber mount on the middle right corner. The speedo sensor looks fine also. If it is not working take the bolt out on the hold down and then remove the sensor. Inspect the gear on the end, and take a light and shine it into the transmission. There is also a plastic gear in there that tends to fall from the carrier or get stripped. Don't worry, the gear oil isn't that high so you won't make a mess removing it.
     
  4. anguem

    anguem New Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Aug 11, 2014
    Ok but do you know what the very large rod to the right of the pic is? It's threaded and has a bit on it??
     
  5. CC'S95GT

    CC'S95GT Legend

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    I think it's a pipe from the smog pump. Hard to tell without seeing further back or the other side of the trans.
     
  6. anguem

    anguem New Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Aug 11, 2014
    [​IMG]

    Here's another pic from farther away. Wtf is it? Lol
     
  7. ttocs

    ttocs Legend

    Messages:
    25,508
    Likes Received:
    2,508
    Joined:
    Oct 9, 2009
    Location:
    Evansville Indiana
    there is some plumbing around the area of the cross over on the pipes that leads back up to the front for I think the smog pump.
     
  8. CC'S95GT

    CC'S95GT Legend

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    that's it. smog pump tubing.
     
  9. SVTstang96

    SVTstang96 Well-Known Member

    Messages:
    1,262
    Likes Received:
    6
    Joined:
    Jan 26, 2010
    Location:
    Dubuque, Iowa
    Yep smog pipe tubing....
     
  10. anguem

    anguem New Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Aug 11, 2014
    Wow never knew it went that far back. How hard is it to remove it. I don't like the idea of it just hanging there
     
  11. CC'S95GT

    CC'S95GT Legend

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    It's supposed to be connected to the back of both heads and to the smog pump.
    All ot can be removed but you'll need plugs on the back of the heads and on the midpipe.
    Where is your mid pipe? My o/r H still had the connection for the smog pump.