Worried about My KB

Discussion in 'The Garage' started by 95KBGT, Sep 4, 2006.

  1. 95KBGT

    95KBGT Legend

    Messages:
    5,413
    Likes Received:
    0
    Joined:
    Apr 7, 2006
    So i thought i filled her up at my tune up. I put in Mobil 1 full sythetic. It was right under the top line on the dipstick. I went to a car show last night and i believe it read just at the bottom line. I dont see any leaks, and the car is not smoking, am i just on crack? DId i make a mistake, should i have let the KB warm up then re check like you do engines? someone tell me its normal, or im in the clear, im starting to freak
     
  2. Lightning Struck

    Lightning Struck Legend

    Messages:
    23,204
    Likes Received:
    2
    Joined:
    Jan 12, 2006
    I'm not familiar with the oiling habits of a KB, but it sounds like you may have a problem :-\ did you check your water tank ( remember the little problem you had a week back :'() If you put the oil in and its not there now.......it went somewhere :dunno: I'm not trying to get you up-tight but I'd be shitting bricks right now. :-[
     
  3. 95KBGT

    95KBGT Legend

    Messages:
    5,413
    Likes Received:
    0
    Joined:
    Apr 7, 2006
    well there is still oil in there (the dipstick is EXTREMLEY hard to read) its just lower than what i thought it had in it....maybe it was so dry it used 2oz of oil?
     
  4. Lightning Struck

    Lightning Struck Legend

    Messages:
    23,204
    Likes Received:
    2
    Joined:
    Jan 12, 2006
    Hmmm, man I hate to try to guess cuz like I said I'm not very knowledgeable about blower's oil consumption. I would keep a CLOSE EYE on it for a while, and mind where you park and try to remember to look for oil spots before you pull off. Look out for smoke from burning oil too.........good luck with it, hopefully it was just a goof and you didn't put as much in as you thought you did :dunno:
     
  5. 95KBGT

    95KBGT Legend

    Messages:
    5,413
    Likes Received:
    0
    Joined:
    Apr 7, 2006
    ok heres whats stumping me. If its leaking to the outside, #1 i should see it #2 there should be shinny spots on the motor #3 there should be oil spots where i parked....theres not. If its leaking on the inside, it should #1 run like shit #2 smoke like a mofo. and its not. maybe it was just thirsty? :dunno:
     
  6. Lightning Struck

    Lightning Struck Legend

    Messages:
    23,204
    Likes Received:
    2
    Joined:
    Jan 12, 2006
    I guess it could be, didn't you say when you took care of your trouble last week that it was " bone dry" ???. I guess its possible that it indeed was dry as dust and when you put the oil in, it ran thru the system re- lubing everything and that resulted in a lower level now, than what it showed when you first put it in.
     
  7. d_punch

    d_punch Active Member

    Messages:
    334
    Likes Received:
    0
    Joined:
    Jul 12, 2006
    i would top it off again and keep a close eye to it.
    i would also check the cooling system again, if it get hot enough the oil will just evaporate.

    J.R the guy with the color changing vert with chromed out engine bay that you see in the top sometimes. he had a KB and he got rid of it cause the oil was dissapearing in it. he would check it and it would be bone dry.