1997 gt Squeaking

Discussion in 'Suspension and Brakes' started by LR97gt, Jan 8, 2015.

  1. LR97gt

    LR97gt New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Jan 6, 2015
    Location:
    Circleville, ohio
    My 1997 gt is squeaking whenever I go to make a turn. Sounds like something is rubbing together. I don't know much about suspension,just wondering if you guys could help me out
     
  2. the5.ohh

    the5.ohh Legend

    Messages:
    9,555
    Likes Received:
    108
    Joined:
    Oct 15, 2012
    Location:
    Shaolin, NY
    I have the same thing. Either balljoints or tierod ends. Check em.
     
  3. LR97gt

    LR97gt New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Jan 6, 2015
    Location:
    Circleville, ohio
    How do I know if they are bad. And most of the noise seems to be coming from the rear
     
  4. SNorange94

    SNorange94 Member

    Messages:
    115
    Likes Received:
    0
    Joined:
    Mar 12, 2014
    Location:
    Dingmans ferry, PA
    Noise from the rear could be the diff. It could be low or it's time for a service.
     
  5. 1bad95

    1bad95 Well-Known Member

    Messages:
    1,484
    Likes Received:
    2
    Joined:
    May 6, 2009
    I'm guessing your shocks or control arm and rear diff housing bushings are shot if you are hearing it in the rear going over bumps

    Sent from my XT1080 using Tapatalk
     
  6. the5.ohh

    the5.ohh Legend

    Messages:
    9,555
    Likes Received:
    108
    Joined:
    Oct 15, 2012
    Location:
    Shaolin, NY
    Ah in the rear. Then I'd check the rear upper and lower control arm bushings, aswell as the rear upper axle bushings. How old are the shocks?
     
  7. Orange 94

    Orange 94 Moderator Staff SN95 Supporter

    Messages:
    10,855
    Likes Received:
    387
    Joined:
    Oct 21, 2012
    Location:
    Alberta Canada
    likely a suspension issue, not engine. Moved to suspension section.
     
  8. LR97gt

    LR97gt New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Jan 6, 2015
    Location:
    Circleville, ohio
    Sorry man I'm new to this forum thing and couldn't find the suspension section
     
  9. LR97gt

    LR97gt New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Jan 6, 2015
    Location:
    Circleville, ohio
    I'm not sure how old the shocks are. I've owned the car for almost a year now and it's been doing it since I bought it. The noise doesn't happen when going over bumps, only when I turn. This car was pieced together from what I can tell. It used to be built and raced from what I have looked up on the internet. Hell the guy that used to own it may have been a member on here. I could put the link with all the info with all the parts it had on it at the time to see if you guys recognize it.
     
  10. LR97gt

    LR97gt New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Jan 6, 2015
    Location:
    Circleville, ohio
  11. 1bad95

    1bad95 Well-Known Member

    Messages:
    1,484
    Likes Received:
    2
    Joined:
    May 6, 2009
    If it does it when turning I would check your ball joints

    Sent from my XT1080 using Tapatalk
     
  12. 1bad95

    1bad95 Well-Known Member

    Messages:
    1,484
    Likes Received:
    2
    Joined:
    May 6, 2009
    Just saw in the link you have coil overs, could also be them making noise

    Sent from my XT1080 using Tapatalk
     
  13. LR97gt

    LR97gt New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Jan 6, 2015
    Location:
    Circleville, ohio
    No I don't have coilovers anymore. That was the previous owner that built it. They put it all back to stock now. The only things done to it are pi swap, aftermarket H pipe, Caster camber plates and it's lowered 1.5in all the ways around
     
  14. 1bad95

    1bad95 Well-Known Member

    Messages:
    1,484
    Likes Received:
    2
    Joined:
    May 6, 2009
    Ohh ok. Yeah I would def check balljoints if its doing it when turning

    Sent from my XT1080 using Tapatalk