95 tranny question

Discussion in 'Drivetrain' started by MikeBo, May 20, 2015.

  1. MikeBo

    MikeBo New Member

    Messages:
    48
    Likes Received:
    2
    Joined:
    May 15, 2013
    Well I have a 1995 GT with 50,000 miles, it has a 331 in it making about 340 horses. Has the factory manual Transmission got a fresh clutch when I put the motor in about 4k miles ago. I put a steeda shifter in myself several months ago. My problem is that it won't shift into 1st or reverse on occasion, if you take your foot off the clutch it will go in. Is this the transmission or does it have to do with my shifter install. It does seem to get worse when it's hot?
     
  2. lutter94

    lutter94 Well-Known Member

    Messages:
    3,011
    Likes Received:
    133
    Joined:
    Apr 11, 2008
    Location:
    South Dakota/Iowa
    I think thats a common T5 problem.....I put a 99 V6 T5 in my car last summer and have yet to have problems. Sometimes it isn't "super easy", but I wouldn't call it a problem yet.....
     
  3. MikeBo

    MikeBo New Member

    Messages:
    48
    Likes Received:
    2
    Joined:
    May 15, 2013
    Does the fix require a rebuild? I assume it would.
     
  4. MikeBo

    MikeBo New Member

    Messages:
    48
    Likes Received:
    2
    Joined:
    May 15, 2013
    Any other thoughts, I would appreciate it
     
  5. Mrstangerbanger

    Mrstangerbanger Well-Known Member

    Messages:
    1,249
    Likes Received:
    28
    Joined:
    Jan 14, 2011
    Location:
    CHICO , California, United States
    Time for an astro or g force t5.