Ever feel a trans move while driving?

c3pbro

New Member
Joined
Jul 11, 2015
Messages
31
Reaction score
0
So the craziest thing happened yesterday while I was driving, I down shifted and it felt like the trans moved forward. This thing has been a ball of problems but now that I sorted out the electrical problems I logged 150 miles on it, and the trans makes tons of noise. It grinds from time to time going gear to gear. I got under the car today and noticed these two bolts going through the crossmember that didn't look right and all my u joint bolts were backed almost all the way out.

Could the missing nuts be causing all these problems?
 
OP
OP
C

c3pbro

New Member
Joined
Jul 11, 2015
Messages
31
Reaction score
0
I didn't do the trans and motor swap but I was told brand new ones were installed...

Although the pile of problems I've had since I got it back I wouldn't doubt that they weren't
 

Royal96

Active Member
Joined
May 30, 2015
Messages
316
Reaction score
0
Location
Cincinnati, OH
I've never felt it move forward but definitely have felt it move side to side (think rolling) under hard acceleration
 
OP
OP
C

c3pbro

New Member
Joined
Jul 11, 2015
Messages
31
Reaction score
0
Trying to post a pic of the crossmember but it won't let me
 

evilcw311

Most Evil Member!
SN95 Supporter
Joined
May 9, 2010
Messages
7,459
Reaction score
2,103
Location
Louisville, KY
I did all new mounts when I rebuilt my car this last time.

Less then 5k later motor was siting a little sideways when we pulled for current build cause one of the new mounts was jelly.


This message courtesy of crapatalk!
 
OP
OP
C

c3pbro

New Member
Joined
Jul 11, 2015
Messages
31
Reaction score
0
I did all new mounts when I rebuilt my car this last time.

Less then 5k later motor was siting a little sideways when we pulled for current build cause one of the new mounts was jelly.


This message courtesy of crapatalk!

I would hope they last longer then 150 miles in my case haha.
 
OP
OP
C

c3pbro

New Member
Joined
Jul 11, 2015
Messages
31
Reaction score
0
Sorry for the late reply, been gone.

I have the t45 in it. I ordered a crossmember from late model resto while I was gone. Tonight I was putting it in, got it mounted but the old nuts off the center two bolts had fallen off the car at some point and I don't know what size they are. Anyone know?
 

Latest posts

Forum statistics

Threads
75,170
Messages
1,456,895
Members
13,700
Latest member
Ronnied

Members online

Top