found a solution to the banging in my front suspension.

daltonduree

Active Member
Joined
Aug 7, 2013
Messages
362
Reaction score
0
Location
omaha/lincoln, nebraska
well i think i found a solution the the banging in my front suspension. im replacing everything. control arm bushings, stabliser bar bushings, ball joints, shocks, shock mounts,while im ther doing cobra brakes and rotors.
 

kb1982

Active Member
Joined
Aug 10, 2013
Messages
591
Reaction score
4
Location
Kentucky
Darn, i thought i was gonna find the answer to lifes biggest mystery, but that should get rid of the banging lol.
 

daltonduree

Active Member
Joined
Aug 7, 2013
Messages
362
Reaction score
0
Location
omaha/lincoln, nebraska
i did moog bushings and moog problem solver greasable ball joints. kyb gr2 shocks and mounts. idk what my cc plates are but they are fine. im using oreilys remaned cobra calipers. both are real pbr aluminums. one has cobra on it and the other looks like its been machined off. for rotors using ebay drilled and slotted brakemotive rotors with powerstop pads
 

TanTop94

Well-Known Member
Joined
Feb 19, 2012
Messages
2,030
Reaction score
134
Location
Maryland
I'm just glad he didn't find out it was me if his back seat. If you know what I mean;)
 

Ferocious

Post Whore
SN95 Supporter
Joined
Jun 1, 2011
Messages
12,255
Reaction score
592
Location
San Diego
He meant fix it (regarding the banging in your front suspension)
 

9838stang

Well-Known Member
Joined
Sep 13, 2010
Messages
2,548
Reaction score
169
Location
Minneapolis,MN
I have an issue with my suspension banging around. I have upgraded shocks struts springs bump steer and cc plates all at once. 4000 miles later i had this loud banging going on. found out that one of my struts, the nylon lock nut, the nylon itself completely wore out and was gone. so it came loose. got a new nylon lock nut and works great now no noise
 

daltonduree

Active Member
Joined
Aug 7, 2013
Messages
362
Reaction score
0
Location
omaha/lincoln, nebraska
well after replacing everything nothing but the stablizer bar bushings were toast. the shocks may have been maxing out. also found that one of the bolts out of the two for my motor mount are broken off in the block... great. i saw my longtubes are touching the unibody. and it may have all just been really loose
 

daltonduree

Active Member
Joined
Aug 7, 2013
Messages
362
Reaction score
0
Location
omaha/lincoln, nebraska
so today while installing the cobra calipers one of the banjo bolts striped out the caliper... i had to put a helicoil in there and that was very nerve racking.
 

Latest posts

Forum statistics

Threads
74,483
Messages
1,447,431
Members
13,362
Latest member
CampTheChamp

Members online

No members online now.
Top