GT wont run without gas prime???

ford96gtconv

New Member
Joined
Dec 25, 2012
Messages
2
Reaction score
0
]My car has been sitting for over year, have broken back and clutch was fubared. Finally swapped clutch and PP out works great, went back to a stock clutch.
Now charged battery for 2 days hit the key no start, squirt gas into CAI/throttle body and runs, will run untiil I turn off than won't restart. I swapped the throttle position sensor and the 3 wire plug, thought that was the problem wire were all exposed and rotten. Wehn the car does start with help(prime with gas) is runs but when I try to gas it falls on it's face.Fells like when you have CAI off, will idle will throttle up slowly, but if I punch it it stalls and than have to prime again.
Any ideas all of a sudden this is my son's only transportation.


I call this car Frankenstang, 01 Gt with a 02 Police Intercepter swap
 

JKady

Active Member
Joined
Mar 20, 2013
Messages
266
Reaction score
1
Location
Graham, WA
Sounds like bad gas to me, drain the year old junk out and put some fresh fuel in it. Wouldn't hurt to check fuel pressure though.
 

CC'S95GT

Post Whore
Joined
Apr 19, 2008
Messages
10,738
Reaction score
172
Location
Hampton ,Ga.
Sounds like bad gas to me, drain the year old junk out and put some fresh fuel in it. Wouldn't hurt to check fuel pressure though.

change the fuel filter too.
You can rent a fuel pressure tester from the parts house. your supposed to have 40psi with the vacuum removed from the regulator, While your there pick up a haynes/chilton manual.
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
28,894
Reaction score
4,220
Location
Evansville Indiana
start simple and check your fuses. Don't bother with the maual, pull each one out inspect it and then replace it if needed. Do the box under the dash and the hood, if they are all good check the inertia switch in the trunk.
 

Latest posts

Forum statistics

Threads
75,598
Messages
1,462,979
Members
13,862
Latest member
Oderekrodgers

Members online

Top