Hanging idle

Discussion in '94-95 5.0 - Specific' started by Spyder, Apr 20, 2007.

  1. Spyder

    Spyder Active Member

    Messages:
    614
    Likes Received:
    0
    Joined:
    May 5, 2006
    My car likes to have a hanging idle sometimes. For some reason it will hang at almost 2k and wont drop, not even at a complete stop. The weird things is that it will idle normal sometimes, the other times it will hang and not drop.
     
  2. ryclef331

    ryclef331 Well-Known Member

    Messages:
    2,913
    Likes Received:
    9
    Joined:
    Jan 20, 2006
    Check three things....

    1) Ensure the that the throttle body IS closing all the way. With the engine off, push the throttle down slowly and release it slowly. Get out and go under the hood. Grab the throttle cable guide on the body....and try to twist the throttle further shut. If if move just slightly...even ever so slightly, something is sticking and not letting it close all the way. Rare but it could happen

    2) Check TPS voltage. If your TPS shits on you and starts throw excessively high voltage at the ECU, the ECU will bump timing...meaning it revs up. This can cause your hanging idle

    3) Check the IAC. If the IAC is sticking open, it will allow the car to rev up as well. Try taking it off and cleaning it with some carb cleaner. If that doesn't help it, start looking prices on a new IAC.
     
  3. hoss13

    hoss13 Member

    Messages:
    183
    Likes Received:
    0
    Joined:
    Apr 1, 2006
    Yep...more than liklely the IAC. I gave up trying to clean mine and bought a new one, problem fixed.
     
  4. ripper

    ripper Well-Known Member

    Messages:
    3,323
    Likes Received:
    0
    Joined:
    Jan 2, 2007
    Yea i did the same that carbon buildup is like friggin concrete.
     
  5. fast5oh

    fast5oh Member

    Messages:
    105
    Likes Received:
    0
    Joined:
    Jan 21, 2006
    so umm ya anyways i searched for this thread because i know there was one out there for it. but this is my problem. i just installed a trick flow track heat. with a 1 inch spacer and a 75mm throttle body and cold air intake on my 94 gt. now i have this hanging idle issue that i never had before. i just replaced the tps and checked the voltage it was dead even at .95 never moved or jumped. so i dont under stand what else i could adjust to get it back to normal or do i just have to deal with it because its kinda gay going down the road and shifting like your not taking your foot off the gas :lame: so any input would be great thanks guys.
     
  6. ryclef331

    ryclef331 Well-Known Member

    Messages:
    2,913
    Likes Received:
    9
    Joined:
    Jan 20, 2006
    Is your throttle body new? Did you clean it with anything? Check your throttle blade stop screw as well. What brand throttle body? Answer those and get back to me. Also, read the sticky at the top of the section
     
  7. fast5oh

    fast5oh Member

    Messages:
    105
    Likes Received:
    0
    Joined:
    Jan 21, 2006
    i got it fixed its bbk gasket was riped so fixed it up and she is driving smooth. loving the intake as well pulls much harder now.