Hanging rpm's 4.6

Discussion in '96-04 - 2V Specific' started by gumby5.0, Jul 28, 2015.

  1. gumby5.0

    gumby5.0 Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    May 31, 2009
    I've just recently completed a bullitt intake swap as well as a egr delete on my 2000 gt. She runs good but I'm having a problem with the rpms sticking anywhere between 2000 to 3500 after a drive or a tap on the gas pedal. I've replaced the iac and the tps with no improvement in the issue. There are moments when it does behave and not stick but they are extremely rare. This is driving me nuts! Any help would be greatly appreciated

    Sent from my VS985 4G using Tapatalk
     
  2. 96blak54

    96blak54 Legend

    Messages:
    7,469
    Likes Received:
    779
    Joined:
    Feb 21, 2011
    Location:
    Ky
    Deleted egr without turning it off in the tune?
     
  3. gumby5.0

    gumby5.0 Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    May 31, 2009
    Yea I haven't been able to get a hold of a programmer to do it yet

    Sent from my VS985 4G using Tapatalk
     
  4. 96blak54

    96blak54 Legend

    Messages:
    7,469
    Likes Received:
    779
    Joined:
    Feb 21, 2011
    Location:
    Ky
    Most likely the problem then. Get it tuned out. Let the tuner know exactly what you did or didnt do. They should be able to coach you more.
     
  5. gumby5.0

    gumby5.0 Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    May 31, 2009
    I really didn't think it would cause issues. I'll definitely get it tuned

    Sent from my VS985 4G using Tapatalk
     
  6. gumby5.0

    gumby5.0 Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    May 31, 2009
    Ok I've got the egr tuned out. Still have the hanging high rpm issue. I've checked for vacuum leaks with none found. Im lost

    Sent from my VS985 4G using Tapatalk
     
  7. gumby5.0

    gumby5.0 Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    May 31, 2009
    Also if I un plug the iac while the rpm's are up and hanging it instantly idles perfect

    Sent from my VS985 4G using Tapatalk
     
  8. chris91

    chris91 Well-Known Member

    Messages:
    3,761
    Likes Received:
    198
    Joined:
    Apr 20, 2007
    Location:
    Cincinnati, OH
    Where did you buy the new IAC from? Maybe try the gasket trick on it?
     
  9. gumby5.0

    gumby5.0 Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    May 31, 2009
    I got the iac from Oreilly's. I've really looked into the iac restrictor and I am considering it if all else fails. I've just noticed that if the car is at a standstill after start up warm or cold you can give it all kinds of gas and will come back to idle relatively easy but as soon as you out it in gear and give it gas it'll start to hang. Btw the car is a 5 speed. Another thing I've just noticed is that if you pinch the pcv hose coming off passenger valve cover the car will just about stall out. Is this normal or a sign of a leak?

    Sent from my VS985 4G using Tapatalk
     
  10. lwarrior1016

    lwarrior1016 Moderator Staff SN95 Supporter

    Messages:
    5,650
    Likes Received:
    673
    Joined:
    Sep 22, 2014
    Location:
    South Mississippi
    You should definitely do the IAC mod. SN90FiveOh just went through this whole deal on his new 2v and he ended up fining a spare cam cover grommet from where they bolt down and he put inside the inlet for the iac and the hose fit perfectly over the other side. Ill see if I can get him to put some pictures up.

    Also, where did you get it tuned? Was it local or email? 96blak54 is on to something with the tune I think, because a local tuner on a dyno will be able to correct the hanging rpm.

    Last thing, when you deleted the egr what did you do with the vacuum lines? and did you cap off the header? An exhaust leak will act like a vacuum leak too.
     
  11. SNorange94

    SNorange94 Member

    Messages:
    115
    Likes Received:
    0
    Joined:
    Mar 12, 2014
    Location:
    Dingmans ferry, PA
    I would make sure the throttle cable isn't hanging up. You could try cleaning the MAF also.
     
  12. gumby5.0

    gumby5.0 Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    May 31, 2009
    I ended up tuning the egr off with a sct Handheld. Witch helped some with the hanging idle. I can actually tap the gas and it will idle down most of the time now. I ended up re routing all the vacuum lines, deleting a majority of them and capping the egr at the header and intake manifold

    Sent from my VS985 4G using Tapatalk
     
  13. SN90FiveOh

    SN90FiveOh Active Member

    Messages:
    411
    Likes Received:
    28
    Joined:
    Sep 25, 2014
    Location:
    New Orleans, La
    If you put the tapered side of the valve cover grommet into the IAC port then the hose just slides over it. Takes the inlet size down from ~5/8 to ~5/16
     
  14. gumby5.0

    gumby5.0 Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    May 31, 2009
    I just did this and it definitely helped. Doesn't idle up past 1500 but still idles a little high

    Sent from my VS985 4G using Tapatalk
     
  15. gumby5.0

    gumby5.0 Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    May 31, 2009
    I just did a quick test on the tps voltage and I'm getting .12v at idle and 1.01v at wot. Just about the same numbers I got with the previous tps. Would that be an issue?

    Sent from my VS985 4G using Tapatalk
     
  16. lwarrior1016

    lwarrior1016 Moderator Staff SN95 Supporter

    Messages:
    5,650
    Likes Received:
    673
    Joined:
    Sep 22, 2014
    Location:
    South Mississippi
    Im pretty sure the voltage reading was supposed to go from ~.9v up to ~5v

    This may be your issue.
     
  17. SN90FiveOh

    SN90FiveOh Active Member

    Messages:
    411
    Likes Received:
    28
    Joined:
    Sep 25, 2014
    Location:
    New Orleans, La
    My tps reads .43 to 4.8
     
  18. gumby5.0

    gumby5.0 Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    May 31, 2009
    I just put a brand new set of coils ngk plugs and modded the tps to where I could adjust it. All I can say is she is running like a top now!

    Sent from my VS985 4G using Tapatalk