i need help!!! please!!!

Discussion in 'The Garage' started by RelapsedGT, Mar 26, 2007.

  1. RelapsedGT

    RelapsedGT New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jan 29, 2007
    ok.. at first my car was runnin like crap like the injectors or somethin was clogged.. i ran a couple tanks with fuel injector cleaner in it and it didnt do n e thing.. so then i thought maybe im fowlin plugs.. so i checked the plugs that i put in about a year ago nd the were not even burnt or anything.. u could still c the white.. at first it seemed like it was runnin better but then it ran like crap again.. i can drive it but then when i get up to around 3500 rpm it starts boggin down nd it kinda feels like it does when u r hitting the rev limiter.. i really need help.. i cant stand it bein like this nd i dont want to mess it up even more by drivin it.. can n e one help me.. i would really appreciate it.. what do u guys think it could b? thanks guys
     
  2. Red96GT

    Red96GT Legend

    Messages:
    5,374
    Likes Received:
    0
    Joined:
    Sep 23, 2006
    Does it idle funny?

    and next time it would make it easier if you typed out words like "be" and "and". ;D
     
  3. cmher18

    cmher18 Active Member

    Messages:
    359
    Likes Received:
    0
    Joined:
    Jan 4, 2007
    Fuel filter/wires/spark plugs


    I would due the fuel filter first mine did the same thing. I put a new FORD fuel filter in and was good And its cheap and easy
     
  4. RelapsedGT

    RelapsedGT New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jan 29, 2007
    sorry about the spelling.. i forgot to mention that i did put a new fuel filter on it. and no it doesnt idle funny
     
  5. Anrev

    Anrev Active Member

    Messages:
    380
    Likes Received:
    0
    Joined:
    Feb 16, 2007
    Check your timing.
     
  6. RelapsedGT

    RelapsedGT New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jan 29, 2007
    im still stuck.. anybody else have any ideas? thanks
     
  7. 97vertstang

    97vertstang Well-Known Member

    Messages:
    2,879
    Likes Received:
    1
    Joined:
    Jan 11, 2006
    check ur firing order and look for any vacuum leaks???? do u have any engine codes??? check ur air intake tract, check ur distributor cap and rotor , look for any leaking fluids, any vacuum hoses broken,??? spark plug wires, condition?? timing??we need more info......
     
  8. RelapsedGT

    RelapsedGT New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jan 29, 2007
    ?
     
  9. Teal_Beast

    Teal_Beast New Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Feb 23, 2007
    make sure you dont have a plug that is burnt or melted, aka resting on a header.
     
  10. 68mustang5.0

    68mustang5.0 Active Member

    Messages:
    409
    Likes Received:
    0
    Joined:
    Feb 19, 2007
    Is it a 5.0 or a 4.6?
     
  11. Spyder

    Spyder Active Member

    Messages:
    614
    Likes Received:
    0
    Joined:
    May 5, 2006
    I had a similar problem when I had my 95 gt. It ended that one of my cats fell apart and was blocking the exhaust. Does you exhaust sound choked at all when you hit that point where it stops pulling?
     
  12. TxCobrA98

    TxCobrA98 Legend

    Messages:
    7,976
    Likes Received:
    3
    Joined:
    May 14, 2006
    check your vacuum lines.. you may have a hole in one of them.. they can be hard to spot but i believe you can take it somewhere and they can run a test on it and find it.. im not exactly sure though.. does your car vibrate real bad at idle? any noises that your car makes that seems to be going along with this problem?