Miss fire or floating out help!!!

Discussion in '94-95 5.0 - Specific' started by Buford95gt, Dec 30, 2013.

  1. Buford95gt

    Buford95gt Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Dec 29, 2013
    Location:
    Whitesburg, Ky
    Seems like my car is floating out or miss firing at anything above 4700 rpms. It's a 95 gt stock with nuttin but bolt ons. What could be causing this? Running out of fuel, cam wore, rocker arms maybe?? Any help will
    be much appreciated..
     
  2. white95

    white95 BNR32 or bust Staff Member SN95 Supporter

    Messages:
    14,070
    Likes Received:
    497
    Joined:
    Dec 30, 2007
    Location:
    Prairieville, Louisiana
    How many miles? Stock cam right? Did you recently install any of the mods? Could be an ignition issue or even dirty injectors.
     
  3. Buford95gt

    Buford95gt Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Dec 29, 2013
    Location:
    Whitesburg, Ky
    Yes it's a stock cam, 120,000 lol and all mods have been on it for at least 1 year
    except the headers they have only been on for a month or so.
     
  4. CC'S95GT

    CC'S95GT Well-Known Member

    Messages:
    10,738
    Likes Received:
    171
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    For me, missing at hi RPM's was the coil. I upgraded to a Summit 45,000 voltand the problem went away.
     
  5. Randy

    Randy Well-Known Member

    Messages:
    87
    Likes Received:
    0
    Joined:
    Sep 15, 2013
  6. Randy

    Randy Well-Known Member

    Messages:
    87
    Likes Received:
    0
    Joined:
    Sep 15, 2013
  7. Randy

    Randy Well-Known Member

    Messages:
    87
    Likes Received:
    0
    Joined:
    Sep 15, 2013
    That was my easy fix until I found out I needed coil and plug / wires -tune -upper and lower control arms k member rear seat delete trick flow upper and lower cam heads ect ect.. actually when I removed my roll cage it ran smoother lol And the dry nitrous
     
  8. Saint

    Saint Well-Known Member

    Messages:
    949
    Likes Received:
    25
    Joined:
    Jan 29, 2012
    When mine did that I replaced coil, wires, plugs and cleaned the MAF and it fixed the issue...I'd start there before jinxing yourself by talking about bad cam or rocker arms...start small man. It probably needs a tune up. Check for detonation on the plugs....don't forget to clean the MAF
     
  9. white95

    white95 BNR32 or bust Staff Member SN95 Supporter

    Messages:
    14,070
    Likes Received:
    497
    Joined:
    Dec 30, 2007
    Location:
    Prairieville, Louisiana
    LMFAO!!! You sound like me!! My oil pump went out in my 302 and I ended up with a 410w
     
  10. from6to8

    from6to8 Well-Known Member

    Messages:
    87
    Likes Received:
    0
    Joined:
    Aug 16, 2012
    was the car having any other signs or issues other than the high rpm miss? cause im gona try my stock coil and see what it might do
     
  11. from6to8

    from6to8 Well-Known Member

    Messages:
    87
    Likes Received:
    0
    Joined:
    Aug 16, 2012
    no oil pressure when the pump went out, low pressure, or what? just asking for my knowledge
     
  12. CC'S95GT

    CC'S95GT Well-Known Member

    Messages:
    10,738
    Likes Received:
    171
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    NO
    everything was running correctly any other time. I only had the missfire around 4500 rpm's and higher
     
  13. from6to8

    from6to8 Well-Known Member

    Messages:
    87
    Likes Received:
    0
    Joined:
    Aug 16, 2012
    ok. first thing i will do this morning is put on stock coil and fire up just to see what it does if anything
     
  14. white95

    white95 BNR32 or bust Staff Member SN95 Supporter

    Messages:
    14,070
    Likes Received:
    497
    Joined:
    Dec 30, 2007
    Location:
    Prairieville, Louisiana
    Lost oil pressure and it chewed all the bearings up.
     
  15. from6to8

    from6to8 Well-Known Member

    Messages:
    87
    Likes Received:
    0
    Joined:
    Aug 16, 2012
    oh ok
     
  16. Buford95gt

    Buford95gt Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Dec 29, 2013
    Location:
    Whitesburg, Ky
    Put a street fire 48,000 coil on today and cleaned the maf... Didn't change plugs yet, wires look good they r ford racing 8.8mm...(only 1 yr old)...still misfiring around 4500. Any other simple ideas of what it might be guys?? Also the plugs r auto lite 24s gapped for nitrous... I got a new set of 26s gonna put stock gap on and try them
     
  17. PonyGlued

    PonyGlued Well-Known Member

    Messages:
    89
    Likes Received:
    0
    Joined:
    Jan 24, 2014
    Location:
    down Island, NY
    If you can locate a vacuum gauge it gives a good look at how healthy she is, and its a cheap test. The wires, some in the industry say that they only last a year, but you could test them with a meter and be able to rule that out as the culprit. good luck

    [​IMG]
     
  18. shoua50

    shoua50 Active Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Aug 14, 2013
    Location:
    tennessee
    Sounds to me like u r losing fuel pressure or valve springs could b weak or lifters bleeding down from not enough oil pressure or worn out lifters