On today's episode of WTF is wrong with my car....

joemomma

Well-Known Member
Joined
Dec 9, 2020
Messages
1,311
Reaction score
814
So, this morning leaving for work, fire the car up and it's idling what I would call "rough", almost like it has way too big of a cam. No miss, just running rough like an old carb setup that isn't warmed up yet. Give it a light rev and it clears up some, so I proceed to back out of the driveway. Still running rough, I stop at the upstairs garage and pop the hood, thinking maybe #4 plug wire is off again causing it to miss. Nope, everything is good and tight. Close the hood and drive on in. It is running fine, by the way. No loss of power or anything of that sort. The only issue I notice is the idle is hanging and it's idling higher than normal. Normal on this car is 900 or so, and it's hanging around 1200-1300 RPM when at a stop light. Hop in at lunch, and it's idling rough again with the continued high idle and hanging revs. After lunch the rough idle is gone, but the revs are still hanging. I have a suspicion that when I leave after work it's going to idle rough, and still have high idle/hanging revs.

Am I looking at a vacuum leak here? Car seems to run fine otherwise.
 
OP
OP
joemomma

joemomma

Well-Known Member
Joined
Dec 9, 2020
Messages
1,311
Reaction score
814
A few of the guys over on S197 forum mentioned a dirty IAC, so I'll clean that while I'm at it. I had cleaned it last year when I was chasing idle issues, maybe it's dirty again. If cleaning it doesn't help and no vacuum leak, I'll throw a new one on it. They aren't terribly expensive, and it is likely due.
 
OP
OP
joemomma

joemomma

Well-Known Member
Joined
Dec 9, 2020
Messages
1,311
Reaction score
814
Cleaned the IAC with no change - it appeared to be the OE unit, so I'll just replace it. I didn't have a chance to put the smoke machine together over the weekend.
 

lwarrior1016

Mr. Secondary Timing Chain
Staff
Joined
Sep 22, 2014
Messages
8,711
Reaction score
4,673
Location
South Mississippi
Cleaned the IAC with no change - it appeared to be the OE unit, so I'll just replace it. I didn't have a chance to put the smoke machine together over the weekend.
The aftermarket idle valves are hit and miss as to when they work. Motorcraft would be your best bet.
 
OP
OP
joemomma

joemomma

Well-Known Member
Joined
Dec 9, 2020
Messages
1,311
Reaction score
814
Ordered a Motorcraft one this morning along with a new Motorcraft TFI module. I figure I'll go ahead and replace it while I've got the air filter and stuff out of the way. It looked to be original too.
 

Rod

New Member
Joined
Aug 4, 2022
Messages
37
Reaction score
13
Try cleaning your MAF sensor wires. I have had idle issues over the years that a good, gentle, cleaning cured.
 

Rod

New Member
Joined
Aug 4, 2022
Messages
37
Reaction score
13
IDK. There is a lot of things on the interwebs that say never clean just replace if testing is out of range....BS. Just don't be stupid about it.
 
OP
OP
joemomma

joemomma

Well-Known Member
Joined
Dec 9, 2020
Messages
1,311
Reaction score
814
Cleaned the MAF wires last year while chasing idle issues, but I can clean it again for grins.

Replaced the IAC valve and did a base idle reset, still rough idle. I didn't go for a drive but I'm assuming the revs are still hanging. I'll get the smoke machine assembled this week hopefully and chase down vacuum leaks.
 

Daryl

Well-Known Member
SN95 Supporter
Joined
Apr 5, 2020
Messages
3,105
Reaction score
1,537
Location
SoCal
Nah… car’s dead. Get anew GT500 instead!! ROFLMFAO!
 

bybyz06

New Member
Joined
May 30, 2007
Messages
29
Reaction score
9
Sounds like a TFI. You can do a visual check by popping the cover off the front and look at the film. You’re looking for what looks like exploded cities in the film; if present the TFI needs to be replaced.
 

Rod

New Member
Joined
Aug 4, 2022
Messages
37
Reaction score
13
Oh man! The mention of the TFI made me think...is the timing spout in it's socket? If the initial timing is set really low the engine would be really lopey, it sets the idle higher for setting the timing, and the over all power would be down because the timing wouldn't advance.
 
OP
OP
joemomma

joemomma

Well-Known Member
Joined
Dec 9, 2020
Messages
1,311
Reaction score
814
It is present, looks to be original. I have a Motorcraft replacement waiting to be installed.

I built my smoke machine but didn't really get a chance to test it, it was leaking lol. I need to seal it up better then I can do vacuum leak tests.
 

Latest posts

Forum statistics

Threads
77,715
Messages
1,508,582
Members
15,138
Latest member
Carlos

Members online

Top