Someone want to tell me why this was in my radiator Resi...

95KBGT

Legend
Joined
Apr 7, 2006
Messages
5,413
Reaction score
0
So many of you may know ive been having trouble with running my a/c and overheating. Well today i changed out alot of things. I bought a new OEM radiator, 180 Degree thermostat, New Autolite 23 Spark Plugs. Well i found numerous things wrong with my car.

#1 My KB supercharger had NO oil what so ever. Bone Dry
#2 The support bar in front of the a/c radiator was bent into the radiator causing the radiator to bulge.
#3 Because of #2 My engine radiator was not in the bottom mounts and was way too close to the a/c radiator.
#4 the radiator resivor was not attached at the bottom.
#5 Well this was in my Radiator Back up resivor. Anyone care to guess what this crap is?

I8260003.jpg



Long story short, everything is in order now, Fixed all of the above, and cruising outside in the city today at 103 Degrees F with the a/c on full blast the engine temp didnt see past the M.

-Paul
 

Lightning Struck

Post Whore
Joined
Jan 12, 2006
Messages
23,204
Reaction score
2
glad to hear you got your kinks worked out man, just too bad summer is getting close to being over :D.



your KB didnt suffer any damage with the fact it had no oil? ???

oh yea for the mystery green stuff :-\ I dont know :dunno:
 

95KBGT

Legend
Joined
Apr 7, 2006
Messages
5,413
Reaction score
0
no thank god. i have complained numerous times about being inside my stang at 2am driving back froma party and it being un bearablly hot, and i guess thats the reason, i figured since it had oil 2 months ago when i got my injector tune it had oil now. O well i lucked out and now she puuuurs like a kitten.....ok well maybe she puuuurs like a jet :bunny3:
 

Lightning Struck

Post Whore
Joined
Jan 12, 2006
Messages
23,204
Reaction score
2
95KBGT said:
no thank god. i have complained numerous times about being inside my stang at 2am driving back froma party and it being un bearablly hot, and i guess thats the reason, i figured since it had oil 2 months ago when i got my injector tune it had oil now. O well i lucked out and now she puuuurs like a kitten.....ok well maybe she puuuurs like a jet :bunny3:

well I'm glad it worked out for you :thumb: With the cooler operating temps it should run a little quicker now :dancing6: :dancing6:, at the very least more efficient
 

v6mustang94

Well-Known Member
Joined
Aug 20, 2006
Messages
1,011
Reaction score
1
I have this black gooy gunk under my radiator cap and my back up looks the same as yours. What the hell is it and why is there? I've been wanting to clean it out or something but I have no clue what it is, what should I do?
 

95KBGT

Legend
Joined
Apr 7, 2006
Messages
5,413
Reaction score
0
well by cleaning mine out and getting a new radiator i have gone from driving in 100+ degree weather with my a/c on and my engine temp reading over l to now it reads r/m
 

MeanGrn Gt

Well-Known Member
Joined
May 29, 2006
Messages
3,094
Reaction score
0
If you notice gunk under the cap i would definately flush it as soon as possible.Have you had any cooling issues?


How does the kb feel now that she has oil paul??
 

95KBGT

Legend
Joined
Apr 7, 2006
Messages
5,413
Reaction score
0
runs like a champ. after the overhaul today its like night and day
 

Downshift

Well-Known Member
Joined
Jan 21, 2006
Messages
1,957
Reaction score
0
Damn man, good to hear you got it all worked out. Could have been real bad runnin that KB with no oil im sure. Ive got some crap in my res. bottle but it doesnt look like mud like yours yuck.
 

95KBGT

Legend
Joined
Apr 7, 2006
Messages
5,413
Reaction score
0
its cost me $200 for a new radiator, new plugs, new thermostat and coolant. i highly recommend doing this.
 

SvtBlack95

Well-Known Member
Joined
Jul 27, 2006
Messages
2,594
Reaction score
1
glad to here your car is doin well and also glad your keeping your KB
 
S

scarface

Guest
the green crap is what builds up when your coolant system isnt flushed. Its just what I said it is...crap..lol. Minerals in the mixture break down, some corrode, and others just get junk inthere when its checked. It just settles in the bottom of the overflow tank. Most cars that dont get their regular flushing have that. Mine was full of it when I first got it too.

Glad its running great for you now:)
 

95KBGT

Legend
Joined
Apr 7, 2006
Messages
5,413
Reaction score
0
im definatley keeping the KB now that my heating issues are under control. its like a whole new monster...
 

MeanGrn Gt

Well-Known Member
Joined
May 29, 2006
Messages
3,094
Reaction score
0
maybe the torque monster (kb) had to take a crap and decide the overflow was a good spot??? ;D
 

plUMe.Ok.97

New Member
Joined
Aug 14, 2006
Messages
53
Reaction score
0
WEll i dont have a KB but i definitely know what you mean with the night and day thing. I did a complete tune up on my gt and it feels 10X better. I did all fluids, flushed radiator, plugs and wires, injector cleaner, and fuel filter and it feels like a new car.

if its an automatic the transmission cooler inside the radiator went bad, the black crap might be trans fluid.. Check your trans fluid and if it looks like crap then change it quick or you'll be walking. Also if you use "permanent type" anti freeze like dex-cool then that could aslo be the problem....nothing fluid wise is permanent.

There are a few other "maybes".

Hopefully i've helped a little bit...keep us posted. :)
 

Hellion94

Well-Known Member
Joined
Jun 14, 2006
Messages
1,400
Reaction score
5
When my car started getting really hot all the time, i just flushed the system and took out my thermostat all together, runs B-E-A-utiful now, gets to the O in normal at it's hottest, usually stays right about at the N
 

94twinscrew

Active Member
Joined
Apr 5, 2006
Messages
465
Reaction score
0
95KBGT said:
its cost me $200 for a new radiator, new plugs, new thermostat and coolant. i highly recommend doing this.
Glad to hear that everything work out for you........I told you that you would be happy with a new stocker.lol :pimp2:

um,but now you have a new issue to address.......what happened to the blower oil in the first place? You need to find that leak,because they don't burn oil,it's a sealed case. You might have it weeping past the front bearing seals,which would get into you engine......that could have been your bogging from before.
 

Latest posts

Forum statistics

Threads
74,896
Messages
1,452,726
Members
13,574
Latest member
ZED

Members online

No members online now.
Top