What will cause this in your ccrm?

jacobn4056.

Member
Joined
Jan 16, 2024
Messages
164
Reaction score
27
Hey Folks.
below ive attached a picture of a ccrm that my car blew. Symptoms were car loosing all power. Very low rpm kind of jumpy. Trans feeling like it doesn’t want to be there. No power. And most notably the radiator fan on with this issue by turn of the Key. If the check engine light is on these are the accompanying problems. Ccrm looked to have a burned low fan relay when this resulted in the condition sticking.
I’ve replaced the ccrm with no luck of the fix. This light is intermittent usually. And may result with the clicking of relay. I don’t have a OBD reader or parts store and shops that can get a reading for it.
Beeping box old OBD reader translated to iac valve, I think, but no luck there.
It will run good for a little while then all the sudden. And can’t drive it, it’s intermittent but frequent. I fouled my plugs looking for the problem elsewhere while old ccrm was in car. Where to start? Im thinking a short but maybe someone has saw this before? Do you have any insight or experience into the problem? Hoping I haven’t burned another ccrm.
Thanks people
 

Attachments

  • image.jpg
    image.jpg
    213.4 KB · Views: 9
  • IMG_1871.jpeg
    IMG_1871.jpeg
    154.9 KB · Views: 8
OP
OP
jacobn4056.

jacobn4056.

Member
Joined
Jan 16, 2024
Messages
164
Reaction score
27
This morning the car seems to be doing its deal where it’s engine light and Fan are on always. Including when the engine isn’t running. This is the inside of the new ccrm

the under side looks a little burned but I suppose it could be from soldering
 

Attachments

  • image.jpg
    image.jpg
    183.2 KB · Views: 11
  • image.jpg
    image.jpg
    174.2 KB · Views: 13
OP
OP
jacobn4056.

jacobn4056.

Member
Joined
Jan 16, 2024
Messages
164
Reaction score
27
More than likely this is caused by a water pump leak. Just found it and pulled pump. I’m drying harnesses grounds and wires on the bottom of engine now. It was just enough to not notice and keep those wires saturated.
 

RAU03MACH

Legend
Joined
Apr 23, 2019
Messages
6,740
Reaction score
6,564
Location
NEW MEXICO
from the water pump i dont recall ever seeing water run up hill
water pump dose sit lower
but ok
 
OP
OP
jacobn4056.

jacobn4056.

Member
Joined
Jan 16, 2024
Messages
164
Reaction score
27
Water running downhill was the problem.
There are harnesses on either side of oil pan. And a drip at all had no way to dry.
 

RAU03MACH

Legend
Joined
Apr 23, 2019
Messages
6,740
Reaction score
6,564
Location
NEW MEXICO
but i do believe the top hose on passenger side that box is under that hose and leaking and is seeping in
 
OP
OP
jacobn4056.

jacobn4056.

Member
Joined
Jan 16, 2024
Messages
164
Reaction score
27
Not only harness but there are a lot of things under there. Including other electronics. Connections. Grounds. This was saturated. I don’t think I burned wires too bad or at all. But the water pump kept those electrical components wet. As I didn’t run the car long enough for heat to evaporate the leak.
 
OP
OP
jacobn4056.

jacobn4056.

Member
Joined
Jan 16, 2024
Messages
164
Reaction score
27
Hey folks.
Alright im finally wrapping up on my Mustangs electrical issues and refresh& replace. Tomorrow she’ll run. I took care of everything major that may have been a barrier to the problem.

Coolant leak flow saturation) (was not noticeable and never dried) I never got hot enough to evaporate so a little water Sit for a time. Kept things wet around my oil pan and lower harnesses. Water pump bolts.

Ccrm burns.
Distributor replacement it’s set to 0 on compression ready to crank and advance.

Ecu capacitor burn.
Checked coolant fan for wear.
fan harness for burns.
It’s all good.

Share your bad ground locations and bear in mind I’ll be doing all of the hard work of tracing ground tomorrow.
 

Attachments

  • IMG_2349.png
    IMG_2349.png
    827.9 KB · Views: 1
  • IMG_2350.png
    IMG_2350.png
    966.4 KB · Views: 0
  • IMG_2339.jpeg
    IMG_2339.jpeg
    185.1 KB · Views: 0
  • IMG_2337.jpeg
    IMG_2337.jpeg
    726.5 KB · Views: 1
  • IMG_2333.jpeg
    IMG_2333.jpeg
    315.4 KB · Views: 1
Last edited:

Latest posts

Forum statistics

Threads
77,480
Messages
1,503,323
Members
14,950
Latest member
JohnnyMac

Members online

Top