What do you guys think.....

Downshift

Well-Known Member
Joined
Jan 21, 2006
Messages
1,957
Reaction score
0
Ok so lately my car has been running pretty crappy at idle. For example, sometimes it tries or actually does stall and I can smell gas really bad when it does this maybe because I have no cats. And when I get on the gas pretty good from around 4k+ I have some pretty bad knock. Now I have been noticing a slight stumble like a misfire or seomthing right at 1800 or so RPMS in any gear, not all the time but 50% maybe. I have had the car 5 or so months and When I bought it I replaced the plugs/cap and rotor/ plug wires. What do you guys think it could be? Just running to rich down low and lean up top? What usually causes a stumble or misfire type thing under accelaration? Thanks in advance.
 

yellowgt

Member
Joined
Mar 1, 2006
Messages
230
Reaction score
0
Sounds to me like it could be a timing issue.

My car use to do the same thing until I realized the timing was set at 22*
 

Downshift

Well-Known Member
Joined
Jan 21, 2006
Messages
1,957
Reaction score
0
Snakebit said:
check the timing

Ill go out and check the plugs in a little bit. As for the timing, I dont know how first off :lame: i know i know. And I had my friend do it a couple months ago and he said he couldnt get a good read of it and the lines were to hard to see. Maybe Ill go borrow another friends timing light and give it a shot. How do you check the timing? Thanks guys Ill go look at the plugs.
 

Latest posts

Forum statistics

Threads
74,891
Messages
1,452,683
Members
13,573
Latest member
ISmeelBaon

Members online

Top