2003 Mach 1 "Restomod" Project BadMach

OP
OP
Deceptive GT

Deceptive GT

Active Member
Joined
Nov 15, 2014
Messages
323
Reaction score
115
Location
Nashville, TN
@RAU03MACH, the engine going in should be a blast even before the blower goes on.

I am using a WAP block, just in case the rods decide to say “peace out”, forged crank, 15+ Coyote/boss rods, pistons are supposed to come out of production on May 17th, stock heads with a valve job, new exhaust valve seats, upgraded valvsprings, GT500 lash adjusters and followers, custom cams, 10” PSR lower with 1/2” spacer.

The CR will be right at 11:1 and I’m going to start out with a 10% lower and a 4” blower pulley.

From what I can see, the 4.6 P1 hp record is 605rwhp. So……
 

RAU03MACH

Legend
Joined
Apr 23, 2019
Messages
6,624
Reaction score
6,358
Location
NEW MEXICO
Sounds about right
The only thing I'm changing on mine is rods and pistons
Flat tops

I already have a street strip shift kit in my transmission
And 373 gear so adding a 4 valve should be good
Not trying to break records just a cruse around and have fun car
Just trying to get it to my mach 1 compared

The blower on my cobra is way fun
 
OP
OP
Deceptive GT

Deceptive GT

Active Member
Joined
Nov 15, 2014
Messages
323
Reaction score
115
Location
Nashville, TN

A few people were asking me about the LARP X Pipe so I removed the Prochamber and now I have a noise at the X Pipe. Maybe a leak, I need to check the connections again, they looked good.

This unfortunately kept me from installing the MS3PNP and starting that.

0F9C4182-6EA1-451E-90B1-EDC53D3788B5.jpeg

I swapped out the 30psi boost gauge for a 15psi one. The car won’t need to make a ton of boost for the goals.

10A5507F-56AE-4CC3-8774-5BA188356BED.jpeg
Last, I installed the KnuKonceptz Ultimate Battery Terminals. The factory ones were destroyed and not making right connections anymore.
 
OP
OP
Deceptive GT

Deceptive GT

Active Member
Joined
Nov 15, 2014
Messages
323
Reaction score
115
Location
Nashville, TN
View attachment 17931View attachment 17931

Update on the Mach 1. I put the SOS Pod with the Speedhut EGT and Boost Gauge in the car so it is not sitting in the garage where my dumbass will possibly break it.

Yesterday I decided to put a few miles on the car, 5 to be exact and things did not go so well.

The car runs hard, no doubt, however I doubt I will put anymore miles on this engine. I have been seeing an issue every now and then where, at idle, the oil pressure gauge wigs out and falls to zero then goes right back to normal. I have not had any noise other than possible tensioner noise at startup so I figured it is just the shit Melling Timing Components.

I took the car to the local Detailer’s Garage to get a foam cannon and some other stuff. When I got there I notice the oil pressure at zero when at idle but as soon as I blipped the throttle it came back to normal and stayed. This time it concerned me but no noise still.

Went in to get the stuff and got back in the car there was a noise about 8 times which was on a consistent interval then went away and never came back. But, the oil pressure gauge kept dropping to zero at almost every stop but again, a slight blip in throttle would bring it back up.

The guy who built the engine is supposed to be somebody that the Saleen and Shelby guys go to for their modular builds. I don’t know who is to blame for this engine. It has 310 miles on the engine, dyno sheet shows decent power for a low compression NA engine, I am sure being a stroker helped that. But I cannot trust the engine at this point.

The good news is that I found the, what are said to be ported heads, are DB castings so I think the engine will get pulled sooner to use these heads instead of the AGs I have.

I think I am selling the Procharger P1SC-1H and bracket and getting a Vortech V1 Si.

I am goin to sell the BBK Catted X Pipe and Aluminum Mac Prochamber.

I need to get the crank pulley puller for the Coyote so I can finish taking it apart in preparation for it’s rebuild and install in the GT and then pull the Mach 1 in and start disassembly for the new engine since there is no point in driving it anymore and risking damage.
 
OP
OP
Deceptive GT

Deceptive GT

Active Member
Joined
Nov 15, 2014
Messages
323
Reaction score
115
Location
Nashville, TN
BBAB8308-F315-4299-82BE-55BE270EB26F.jpeg

D6D82F89-F185-452B-A65A-A3153EC074CC.jpeg

Got a few personal touches for the Mach 1 in.

Received the trunk lid cover/mat from Grand Design Mats and it looks great.

My plate came in so I picked that up.

Last, I grabbed the thin (99-(early?)03) passenger A Pillar to match the SOS gauge pod.

I think the Mach 1 is a late 03. It has the thick A Pillars and DB heads.
 

white95

Apex Junky
Admin
Joined
Dec 30, 2007
Messages
20,370
Reaction score
8,255
Location
Prairieville, LA
View attachment 18247

View attachment 18248

Got a few personal touches for the Mach 1 in.

Received the trunk lid cover/mat from Grand Design Mats and it looks great.

My plate came in so I picked that up.

Last, I grabbed the thin (99-(early?)03) passenger A Pillar to match the SOS gauge pod.

I think the Mach 1 is a late 03. It has the thick A Pillars and DB heads.

I like the pillar pod!
 

lwarrior1016

Mr. Secondary Timing Chain
Staff
Joined
Sep 22, 2014
Messages
8,412
Reaction score
3,851
Location
South Mississippi
Those gauges look really good too. It’s got factory style needles and black background so it should match the Mach gauges nicely.
 

Latest posts

Forum statistics

Threads
77,354
Messages
1,499,944
Members
14,844
Latest member
MWTULLY22
Top