Please Somebody Help

Discussion in 'The Garage' started by CanaryGT, Nov 17, 2006.

  1. CanaryGT

    CanaryGT Well-Known Member

    Messages:
    3,688
    Likes Received:
    2
    Joined:
    May 22, 2006
    Location:
    Prescott
    :help2:
    Okay, I have two issues with my car right now. First is when I start her up in the morning, my ABS light goes on. My breaks act funny when I push them at the stop signs etc. They have almost a pumping feel to them. But when I drive my car for like 5 mins, turn off the ignition and turn it back on its fine. No light, no weird braking issue. Any thoughts??

    And for number two.... check engine light will randomly appear. Its like completely random. Its not when im giving throttle, braking or even clutching.... just when it feels like it. Then it goes off.... then on again... Any thoughts on that one. Thanks Guys, if you have and suggestions it will be extremely appreciated!!!
    :help2:
     
  2. jpajkos

    jpajkos Active Member

    Messages:
    622
    Likes Received:
    0
    Joined:
    Jun 20, 2006
    Not sure about the brakes but have you tried pulling codes with the OBD reader?
     
  3. scarface

    scarface Guest

    are you low on brake fluid? Maybe an ABS sensor gone bad.
     
  4. OnyxCobra

    OnyxCobra Legend

    Messages:
    14,794
    Likes Received:
    233
    Joined:
    Apr 8, 2006
    Location:
    Rochester, NY
    I was going to suggest the ABS sensor also, i think my Probe has a similar problem
     
  5. CanaryGT

    CanaryGT Well-Known Member

    Messages:
    3,688
    Likes Received:
    2
    Joined:
    May 22, 2006
    Location:
    Prescott
    Brake Fluid Is Okay. Sensors I have not checked. How do I pull a code from the engine to figure out why the light is going on?
     
  6. Fryrice

    Fryrice Active Member

    Messages:
    574
    Likes Received:
    0
    Joined:
    Jul 9, 2006
    I would say that problem #2 is due to the fact that you have an O/R H-pipe . Do you have mil eliminators ?

    I have a MAC O/R H with Flows also. My light stays on cuz Im to lazy to put the mil's on ,even though I installed the exhaust system myself,lol. I guess I had a burst of energy that day.