Rear suspension unlevel

krtw

New Member
Joined
Apr 7, 2007
Messages
11
Reaction score
0
Hey,

I posted this on the corral, shortly after I found this site so I'll ask you too. The passenger side of my car sits ~1/4" higher in the rear as compaired to the drivers side. Its not often that I really look at the passenger side of the car I guess, but after taking some pictures I started noticing the car looked unlevel from behind. At first I thought it was just the picture but after measuring I can see its for real. Anybody encounter this before? Tonight I jacked the car up and I can't really see anything obviously wrong. I'll try to take the springs out and see what the deal is. Thanks for any ideas or suggestions.
 
G

GREG@SN95

Guest
look for anything bent or broken first off...

It sounds like the spring is munged up...

and make sure you ain't got a flat, lol...
 

97blackgt

Well-Known Member
Joined
Dec 8, 2006
Messages
1,064
Reaction score
2
check springs and shocks/ struts

one of those are proably worn out and needs to be replaced
 

ryclef331

Well-Known Member
Joined
Jan 20, 2006
Messages
2,913
Reaction score
11
shocks and struts won't affect ride height.

Check your rear sway bar. They are prone to break. You didn't mention if the springs were stock or not? You sure you don't have something crazy like a drag launch setup with the air bag in the right rear? Or was the previous owner a lil "hefty?"
 

97blackgt

Well-Known Member
Joined
Dec 8, 2006
Messages
1,064
Reaction score
2
a broken spring or strut that is blown out cant make the car sag???\\ :dunno:
 
OP
OP
K

krtw

New Member
Joined
Apr 7, 2007
Messages
11
Reaction score
0
The springs are not stock they are Ford racing B springs, I had this info in my signature so I did not retype it. No, there is no drag racing launch setup back there. I had these springs installed ~two years ago, they were new at that time.

I removed the springs, they appear fine. They are the same height. The sway bar is fine too. I was looking at the mounting locations and I don't see any differences.

The only thing I have noticed is the upper controll arms are making contact with my exhaust tubing, I suppose that could be it. Either way I need to correct that.

The work continues.......Another day. I love having a garage and another car to drive.

QUESTION: My chiltons manual says to discard the lower arm axis pivot bolt and nut that was removed and replace with a new, is this BS or what? I have never replaced a bolt and nut just because they were removed.
 

97blackgt

Well-Known Member
Joined
Dec 8, 2006
Messages
1,064
Reaction score
2
maybe they are torque to yeild or whatever? :dunno:
 

ryclef331

Well-Known Member
Joined
Jan 20, 2006
Messages
2,913
Reaction score
11
Ok...make sure the springs are clocked right. The tail on the end of the spring should be pointing the same on each side. As for the bolts...I assume your talking about the control arm bolts....just reuse them. No biggie. Look at the tq boxes....where the control arms mount to the car. You might have tweaked of ripped one.
 
OP
OP
K

krtw

New Member
Joined
Apr 7, 2007
Messages
11
Reaction score
0
Hey,

I am back. Figured I would give a report on this issue. I finally finished my week of work so I am back playing with my car. I checked everything and saw no real issues under there except I do believe the springs were not clocked correctly, the pig tails were pointing in opposite directions (one left and one right). I corrected that and I swapped the springs from one side to the other just out of curiosity. Getting the bolts lined up with the axle was a little interesting, but I eventually got 'em in there. So we'll see how it goes tomorrow after I drive it, but right now I am only about 3/16's difference between sides in the rear. I made a mistake in my original post, I had a 3/8" difference originally. Time for a brew..... :drunk:
 

trav_19

Legend
Joined
Dec 18, 2006
Messages
5,615
Reaction score
0
well do you have subframes?? your car could be twisted slightly... or possibly in a wreck before you got it....my guess would be chassis twisted slightly get some sub-frames if you already have not
 

Latest posts

Forum statistics

Threads
77,727
Messages
1,508,838
Members
15,149
Latest member
gregssn96
Top