scosche adapter

phil_the_thrill

Active Member
Joined
Oct 2, 2006
Messages
874
Reaction score
0
i bought the scosche adapter from crutchfield and hooked it up but only my left side speakers would come on. i checked all my connections and they were perfect. has anyone else had this problem?
 

TxCobrA98

Legend
Joined
May 14, 2006
Messages
7,976
Reaction score
5
my scosche adapter worked perfectly. i would get behind there and pull it out to compare the wire's but mines a dvd player and the controller is in the dash too so its to big of a hassle. you are sure your wires are correct?
 

phil_the_thrill

Active Member
Joined
Oct 2, 2006
Messages
874
Reaction score
0
yeah the wiring is pretty much fool proof. i think something must be wrong with my head unit if no one else has had this problem.
 

phil_the_thrill

Active Member
Joined
Oct 2, 2006
Messages
874
Reaction score
0
the hardest part for me was getting the stock unit unplugged. i had to pry the harness out with a screwdriver because the son of a bitch only had a 1/4 inch of slack. i dont even wanna get started on how hard it was to put the stock headunit back in. other than that its just plug and play. i think something must be wrong with my headunit cause only my left speakers would come on but it works fine with the stock one in. $30 shipped for the harness if you are interested. i'm giving up on mine
 

Latest posts

Forum statistics

Threads
75,016
Messages
1,454,473
Members
13,636
Latest member
macsnjets

Members online

Top