Turn Signals

Discussion in '94-95 5.0 - Specific' started by Tattoogod, Nov 30, 2006.

  1. Tattoogod

    Tattoogod Active Member

    Messages:
    278
    Likes Received:
    1
    Joined:
    May 8, 2006
    To those who remember my problem back in the summer..i had no turn signals..well after 3 months of ripping shit out..i finally found the problem. when i went to change my fly wheel and clutch. the top two bolts on the tranny hold up a wiring bracket. well the asshole before me didnt bother putting that bracket back how it was supposed to go..there was a micro hole barely rubbing the tranny and that what caused my freakin 3 month nightmare. thankk God thats over with ;D ;D ;D ;D
     
  2. Eastcoast5.0

    Eastcoast5.0 Member

    Messages:
    238
    Likes Received:
    0
    Joined:
    Jan 28, 2006
    Hmmm thanks, my blinker fuse will blow now after I had a clutch put in.
     
  3. Tattoogod

    Tattoogod Active Member

    Messages:
    278
    Likes Received:
    1
    Joined:
    May 8, 2006
    let me guess the number 1 fuse pops as soon as you turn the key on? and no reverse lights? theres a few wires in flex loom on top of the trans where it mounts to the block.thats where my problem was
     
  4. Eastcoast5.0

    Eastcoast5.0 Member

    Messages:
    238
    Likes Received:
    0
    Joined:
    Jan 28, 2006
    Haha exactly. For the past few years I've had to make friends with mr. car inspector so he'd look the other way, it's such a PITA. Thanks again for the follow up!